summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Hill2020-04-18 21:38:27 +0100
committerTristan Hill2020-04-18 21:59:17 +0100
commitb1c8cc68ece58e7cc0fc432b3f6f46cbe4321eb9 (patch)
tree1feb73427f714ab64372da26bdb84f50e48cb6a3
downloadaur-b1c8cc68ece58e7cc0fc432b3f6f46cbe4321eb9.tar.gz
initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..899457936cda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = roundcubemail-plugin-delete_old
+ pkgdesc = A Roundcube plugin to delete messages older than configurable timespans.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/ron4mac/roundcube_delete_old
+ arch = any
+ license = GPL3
+ depends = roundcubemail
+ source = https://github.com/ron4mac/roundcube_delete_old/releases/download/v1.0.2/delete_old.1.0.2.zip
+ sha256sums = 249438b70593d88cdc5cf456e7d00d43109d1c9a18e9042265a85ac4ca300c87
+
+pkgname = roundcubemail-plugin-delete_old
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e36dec2a9b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Tristan Hill <tristan [at] me [dot] uk [dot] uk [dot] org>
+
+pkgname=roundcubemail-plugin-delete_old
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='A Roundcube plugin to delete messages older than configurable timespans. '
+arch=('any')
+url='https://github.com/ron4mac/roundcube_delete_old'
+license=('GPL3')
+depends=('roundcubemail')
+source=("https://github.com/ron4mac/roundcube_delete_old/releases/download/v${pkgver}/delete_old.${pkgver}.zip")
+sha256sums=('249438b70593d88cdc5cf456e7d00d43109d1c9a18e9042265a85ac4ca300c87')
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/webapps/roundcubemail/plugins"
+ cp -r "${srcdir}/delete_old" "${pkgdir}/usr/share/webapps/roundcubemail/plugins"
+}
+