summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-10-02 21:06:31 +0200
committeroli2015-10-02 21:06:31 +0200
commitfcb540af7f9804e0c1004c5add6d3ce016793f3f (patch)
tree58bec74a193dd03bdfb09ea4c42db67a4d60b0db
downloadaur-fcb540af7f9804e0c1004c5add6d3ce016793f3f.tar.gz
update
-rw-r--r--.SRCINFO23
-rw-r--r--ChangeLog31
-rw-r--r--PKGBUILD63
-rw-r--r--routeconverter13
-rw-r--r--routeconverter-cli8
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9807bd3d193
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = routeconverter
+ pkgdesc = A free tool to edit and convert routes, tracks and waypoints.
+ pkgver = 2.16.3
+ pkgrel = 1
+ url = http://www.routeconverter.de/en
+ changelog = ChangeLog
+ arch = i686
+ license = GPL
+ depends = java-environment>=6
+ depends = libwebkit3
+ optdepends = gpsbabel: for some additional format support
+ noextract = RouteConverterCmdLine.jar
+ noextract = RouteConverterLinux.jar
+ noextract = RouteConverterLinux64.jar
+ source = routeconverter
+ source = routeconverter-cli
+ source = http://www.routeconverter.de/download/RouteConverterCmdLine.jar
+ md5sums = 4bc45e6a1a93656a0deb8956f71b6af8
+ md5sums = fdf570309917df1c1536b7e3c7740b33
+ md5sums = e95c8f2f2fe68054eb9e06370eb2439e
+
+pkgname = routeconverter
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..c98ff1fbe48e
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,31 @@
+2013-01-29 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.8-1 :
+ New version: 2.8.3
+
+2012-06-16 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.7-1 :
+ New version: 2.7
+
+2012-03-14 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.6-1 :
+ New version: 2.6
+
+2012-01-10 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.5-1 :
+ New version: 2.5
+
+2011-08-02 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.4-2 :
+
+2011-05-24 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.4 :
+ Upadated to version 2.4
+
+2010-10-22 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 2.0 :
+ Updated to version 2.0
+
+2010-08-15 Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+ * 1.34pre-1 :
+ Initial package release
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..067b997e2c6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
+pkgname=routeconverter
+pkgver=2.16.3
+pkgrel=1
+pkgdesc="A free tool to edit and convert routes, tracks and waypoints."
+# not sure if 64bit version works - on http://static.routeconverter.com/download/previous-releases/2.16/ there is no 64bit version any more
+arch=(i686)
+#arch=(i686 x86_64)
+url="http://www.routeconverter.de/en"
+license=('GPL')
+depends=('java-environment>=6' 'libwebkit3')
+optdepends=('gpsbabel: for some additional format support')
+changelog=ChangeLog
+source=(routeconverter
+ routeconverter-cli
+ http://www.routeconverter.de/download/RouteConverterCmdLine.jar)
+[ "$CARCH" == "i686" ] && source=(${source[@]} http://www.routeconverter.de/download/RouteConverterLinux.jar)
+#[ "$CARCH" == "x86_64" ] && source=(${source[@]} http://www.routeconverter.de/download/RouteConverterLinux64.jar)
+
+md5sums=('4bc45e6a1a93656a0deb8956f71b6af8'
+ 'fdf570309917df1c1536b7e3c7740b33'
+ 'e95c8f2f2fe68054eb9e06370eb2439e')
+[ "$CARCH" == "i686" ] && md5sums=(${md5sums[@]} '96b38e7eaebc22ba21575e50e1c89bfd')
+#[ "$CARCH" == "x86_64" ] && md5sums=(${md5sums[@]} '8d99d74806864946803131d7ecef9795')
+
+noextract=(RouteConverterCmdLine.jar
+ RouteConverterLinux.jar
+ RouteConverterLinux64.jar)
+
+build()
+{
+ cd "$srcdir"
+}
+
+package()
+{
+ cd "$srcdir"
+
+ install -m 755 -o root -g root -d ${pkgdir}/usr/bin
+ install -m 755 -o root -g root -d ${pkgdir}/usr/lib/${pkgname}
+ install -m 755 -o root -g root \
+ ${srcdir}/routeconverter \
+ ${srcdir}/routeconverter-cli \
+ ${pkgdir}/usr/bin/
+ install -m 644 -o root -g root \
+ ${srcdir}/RouteConverterCmdLine.jar \
+ ${pkgdir}/usr/lib/${pkgname}/
+
+ [ "$CARCH" == "i686" ] && \
+ install -m 644 -o root -g root \
+ ${srcdir}/RouteConverterLinux.jar \
+ ${pkgdir}/usr/lib/${pkgname}/ || true
+
+ #[ "$CARCH" == "x86_64" ] && \
+ #install -m 644 -o root -g root \
+ #${srcdir}/RouteConverterLinux64.jar \
+ #${pkgdir}/usr/lib/${pkgname}/ || true
+
+ ln -s /usr/lib/libwebkitgtk-1.0.so.0 ${pkgdir}/usr/lib/${pkgname}/libwebkit-1.0.so.2
+ ln -s libwebkit-1.0.so.2 ${pkgdir}/usr/lib/${pkgname}/libwebkit-1.0.so
+}
+
diff --git a/routeconverter b/routeconverter
new file mode 100644
index 000000000000..6759f4acdab0
--- /dev/null
+++ b/routeconverter
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/routeconverter
+
+java=`which java`
+java_opts=""
+
+cpu=`uname -m`
+
+jar="/usr/lib/routeconverter/RouteConverterLinux.jar"
+[ "$cpu" == "x86_64" ] && jar="/usr/lib/routeconverter/RouteConverterLinux64.jar"
+
+"$java" $java_opts -jar "$jar" $@
diff --git a/routeconverter-cli b/routeconverter-cli
new file mode 100644
index 000000000000..960589788aa7
--- /dev/null
+++ b/routeconverter-cli
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+java=`which java`
+java_opts=""
+
+jar="/usr/lib/routeconverter/RouteConverterCmdLine.jar"
+
+"$java" $java_opts -jar "$jar" $@