summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-04-18 21:55:44 +0800
committerChocobo12020-04-18 22:01:13 +0800
commit40ef75f59a24a1638ddee59d05eaa4c466c2bfe4 (patch)
tree43af6c1a674bda4392b079dce7f080a394c8aee9
downloadaur-40ef75f59a24a1638ddee59d05eaa4c466c2bfe4.tar.gz
newpkg: routinator-git 0.6.4.r79.g804c74e-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a57fa9b038d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = routinator-git
+ pkgdesc = RPKI validator written in Rust
+ pkgver = 0.6.4.r79.g804c74e
+ pkgrel = 1
+ url = https://nlnetlabs.nl/rpki
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = rust
+ depends = gcc-libs
+ depends = rsync
+ provides = routinator
+ conflicts = routinator
+ options = staticlibs
+ source = git+https://github.com/NLnetLabs/routinator.git
+ sha256sums = SKIP
+
+pkgname = routinator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ab22892b6d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=routinator-git
+pkgver=0.6.4.r79.g804c74e
+pkgrel=1
+pkgdesc="RPKI validator written in Rust"
+arch=('i686' 'x86_64')
+url="https://nlnetlabs.nl/rpki"
+license=('BSD')
+depends=('gcc-libs' 'rsync')
+makedepends=('git' 'rust')
+provides=('routinator')
+conflicts=('routinator')
+options=('staticlibs')
+source=("git+https://github.com/NLnetLabs/routinator.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "routinator"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+check() {
+ cd "routinator"
+
+ cargo test \
+ --release
+}
+
+package() {
+ cd "routinator"
+
+ cargo install \
+ --no-track \
+ --root "$pkgdir/usr" \
+ --path "$srcdir/routinator"
+
+ install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/routinator"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/routinator"
+}