summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2015-10-28 13:38:33 +0100
committerSanpi2015-10-28 13:38:33 +0100
commit4c0db6884b2104ac661447d1274f1ae22fd89000 (patch)
tree5238f99a91501f554d7ec15ecd75393f33cf09b7
downloadaur-4c0db6884b2104ac661447d1274f1ae22fd89000.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f4e5b66c987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = routino-svn
+ pkgdesc = Router for OpenStreetMap Data
+ pkgver = r1832
+ pkgrel = 1
+ url = http://www.routino.org/
+ arch = x86_64
+ license = AGPL3
+ makedepends = make
+ makedepends = subversion
+ depends = zlib
+ depends = bzip2
+ provides = routino
+ conflicts = routino
+ source = routino-svn::svn+http://routino.org/svn/trunk/
+ sha256sums = SKIP
+
+pkgname = routino-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f226ab258740
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/*.pkg.tar.xz
+/*.tgz
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea598d88b832
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=routino-svn
+pkgver=r1832
+pkgrel=1
+pkgdesc='Router for OpenStreetMap Data'
+arch=('x86_64')
+url='http://www.routino.org/'
+license=('AGPL3')
+depends=('zlib' 'bzip2')
+makedepends=('make' 'subversion')
+conflicts=('routino')
+provides=('routino')
+source=("$pkgname::svn+http://routino.org/svn/trunk/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd "$pkgname"
+
+ sed -i 's|prefix=/usr/local|prefix=/usr|' Makefile.conf
+}
+
+build() {
+ if echo $MAKEFLAGS | grep -q -- '-j[2-9]'
+ then
+ error "Routino parallele compilation failed. Please unset -j make flag and relaunch the build."
+ plain "$(gettext "Aborting...")"
+ exit 1
+ fi
+
+ cd "$pkgname"
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+}