summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshtrom2009-08-11 20:24:30 +0000
committershtrom2009-08-11 20:24:30 +0000
commitc1d4bcb5df20921dcd21c060c107b14b477bc712 (patch)
tree3199bfe7b2bd6aff6a82a4232b7718b3c77e8089
downloadaur-c1d4bcb5df20921dcd21c060c107b14b477bc712.tar.gz
[rox-thumbnailers] Added.
git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@176 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf2677797d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = rox-thumbnailers
+ pkgdesc = ROX-thumbnailers generate thumbnails for ROX-Filer using various thumbnailers.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://yuri.bongiorno.googlepages.com/
+ arch = i686
+ arch = x86_64
+ groups = rox
+ license = GPL
+ depends = rox
+ depends = rox-lib
+ optdepends = ffmpegthumbnailer: for video thumbnails using ffmpeg
+ optdepends = totem: for video thumbnails using GStreamer
+ optdepends = totem-xine: for video thumbnails using Xine
+ optdepends = evince: for PDF/PS/DVI documents
+ optdepends = raw-thumbnailer: for raw images
+ optdepends = comix: for comic book archives
+ optdepends = thunar-thumbnailers: for TeX, Grace and OpenDocument thumbnails
+ source = http://denver.sociol.unimi.it/~yuri/rox/ROX-thumbnailers_1.0.0.tgz
+ md5sums = c53e7eb42e54fc8a0673dbf78456d441
+
+pkgname = rox-thumbnailers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dee313393836
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Contributor: Olivier Mehani <shtrom-aur@ssji.net>
+pkgname=rox-thumbnailers
+pkgver=1.0
+pkgrel=1
+pkgdesc="ROX-thumbnailers generate thumbnails for ROX-Filer using various thumbnailers."
+arch=(i686 x86_64)
+url="http://yuri.bongiorno.googlepages.com/"
+license=('GPL')
+groups=(rox)
+depends=(rox rox-lib)
+optdepends=(
+ 'ffmpegthumbnailer: for video thumbnails using ffmpeg'
+ 'totem: for video thumbnails using GStreamer'
+ 'totem-xine: for video thumbnails using Xine'
+ 'evince: for PDF/PS/DVI documents'
+ 'raw-thumbnailer: for raw images'
+ 'comix: for comic book archives'
+ 'thunar-thumbnailers: for TeX, Grace and OpenDocument thumbnails'
+)
+# Nonexistent ArchLinux packages:
+# gnome-nds-thumbnailer
+# swfdec-thumbnailer
+# gnome-xcf-thumbnailer
+install=rox-thumbnailers.install
+source=(http://denver.sociol.unimi.it/~yuri/rox/ROX-thumbnailers_${pkgver}.0.tgz)
+md5sums=('c53e7eb42e54fc8a0673dbf78456d441')
+
+build() {
+ cd "$srcdir/ROX-thumbnailers"
+
+ python -m compileall .
+ python -O -m compileall .
+
+ mkdir -p $pkgdir/usr/share/apps
+ cp -R $srcdir/ROX-thumbnailers $pkgdir/usr/share/apps
+}
+
+# vim:set ts=2 sw=2 et: