summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Mehani2017-01-25 21:21:11 +1100
committerOlivier Mehani2017-01-25 21:21:11 +1100
commitc2f73d21f619da989897bea9e6cce1aa67eff525 (patch)
tree6c5edf42a0629dc23a6f9bbd3a2dae1fad602eae
parent46fdab0e21a04a83e93c88ee789edcc9a902055e (diff)
downloadaur-c2f73d21f619da989897bea9e6cce1aa67eff525.tar.gz
Update URLs and packaging code
Signed-off-by: Olivier Mehani <shtrom@ssji.net>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf2677797d67..eaa86540bcc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,12 @@ pkgbase = rox-thumbnailers
pkgdesc = ROX-thumbnailers generate thumbnails for ROX-Filer using various thumbnailers.
pkgver = 1.0
pkgrel = 1
- url = http://yuri.bongiorno.googlepages.com/
+ url = http://yurib.gitlab.io/
arch = i686
arch = x86_64
groups = rox
license = GPL
+ makedepends = python2
depends = rox
depends = rox-lib
optdepends = ffmpegthumbnailer: for video thumbnails using ffmpeg
@@ -16,7 +17,7 @@ pkgbase = rox-thumbnailers
optdepends = raw-thumbnailer: for raw images
optdepends = comix: for comic book archives
optdepends = thunar-thumbnailers: for TeX, Grace and OpenDocument thumbnails
- source = http://denver.sociol.unimi.it/~yuri/rox/ROX-thumbnailers_1.0.0.tgz
+ source = https://sites.google.com/site/yuribongiorno/ROX-thumbnailers_1.0.0.tgz
md5sums = c53e7eb42e54fc8a0673dbf78456d441
pkgname = rox-thumbnailers
diff --git a/PKGBUILD b/PKGBUILD
index 3fcab06a7ffb..9ef6b89a7711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@ pkgver=1.0
pkgrel=1
pkgdesc="ROX-thumbnailers generate thumbnails for ROX-Filer using various thumbnailers."
arch=(i686 x86_64)
-url="http://yuri.bongiorno.googlepages.com/"
+url="http://yurib.gitlab.io/"
license=('GPL')
groups=(rox)
depends=(rox rox-lib)
+makedepends=(python2)
optdepends=(
'ffmpegthumbnailer: for video thumbnails using ffmpeg'
'totem: for video thumbnails using GStreamer'
'totem-xine: for video thumbnails using Xine'
'evince: for PDF/PS/DVI documents'
- 'raw-thumbnailer: for raw images'
+ 'raw-thumbnailer: for raw images'
'comix: for comic book archives'
'thunar-thumbnailers: for TeX, Grace and OpenDocument thumbnails'
)
@@ -22,14 +23,18 @@ optdepends=(
# swfdec-thumbnailer
# gnome-xcf-thumbnailer
#install=rox-thumbnailers.install
-source=(http://denver.sociol.unimi.it/~yuri/rox/ROX-thumbnailers_${pkgver}.0.tgz)
+source=(https://sites.google.com/site/yuribongiorno/ROX-thumbnailers_${pkgver}.0.tgz)
md5sums=('c53e7eb42e54fc8a0673dbf78456d441')
build() {
cd "$srcdir/ROX-thumbnailers"
- python -m compileall .
- python -O -m compileall .
+ python2 -m compileall .
+ python2 -O -m compileall .
+}
+
+package() {
+ cd "$srcdir/ROX-thumbnailers"
mkdir -p $pkgdir/usr/share/apps
cp -R $srcdir/ROX-thumbnailers $pkgdir/usr/share/apps