summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorm0p2020-12-14 19:16:15 +0800
committerm0p2020-12-14 19:16:15 +0800
commitb96c15196e5068bceb907df3e3c1e4c0ca0d1ae7 (patch)
treebc01164553b59aa36452dcb6fa966a91131c3997
downloadaur-b96c15196e5068bceb907df3e3c1e4c0ca0d1ae7.tar.gz
upload pkg
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5f6ca589212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rozb3-pac
+ pkgdesc = Create ZFS boot environment for every pacman transaction and add GRUB submenu.
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://gitlab.com/m_zhou/rozb3-pac
+ arch = any
+ license = GPL
+ depends = grub
+ depends = coreutils
+ depends = bash
+ depends = util-linux
+ depends = zfs
+ conflicts = rozb3-pac-git
+ source = https://gitlab.com/m_zhou/rozb3-pac/-/archive/0.0.3/rozb3-pac-0.0.3.tar.gz
+ md5sums = 6e4257810d0089de26032d63fc352fad
+
+pkgname = rozb3-pac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4439d64ebfde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Maurice Zhou <ja at apvc punkt uk>
+pkgname=rozb3-pac
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Create ZFS boot environment for every pacman transaction and add GRUB submenu."
+arch=(any)
+url="https://gitlab.com/m_zhou/rozb3-pac"
+license=('GPL')
+depends=('grub' 'coreutils' 'bash' 'util-linux' 'zfs')
+conflicts=('rozb3-pac-git')
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('6e4257810d0089de26032d63fc352fad')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}