summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2021-10-03 17:54:21 -0700
committerChristopher Snowhill2021-10-03 17:54:21 -0700
commit4e3dfdda294aca261a2d61c24d1249de0f8ba10b (patch)
tree8292a7b085c2ae924dfb430f52f2b785037b8f1b
parent7a02f22880750a9764b1d0abb55a3eab78440117 (diff)
downloadaur-4e3dfdda294aca261a2d61c24d1249de0f8ba10b.tar.gz
upgpkg: rpcs3 0.0.18-2
Update dependencies and submodules to only check out what is actually required for building, while leaving out system libraries, and leaving out two submodules that no longer exist
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD51
2 files changed, 18 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a3d7f519931..332d7faeaa0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rpcs3
pkgdesc = Open-source Sony PlayStation 3 Emulator
pkgver = 0.0.18
- pkgrel = 1
+ pkgrel = 2
url = https://rpcs3.net
arch = x86_64
license = GPL2
@@ -34,7 +34,6 @@ pkgbase = rpcs3
depends = curl
options = !emptydirs
source = git+https://github.com/RPCS3/rpcs3.git#tag=v0.0.18
- source = rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
source = rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
@@ -47,18 +46,7 @@ pkgbase = rpcs3
source = git+https://github.com/asmjit/asmjit.git
source = git+https://github.com/libusb/libusb.git
source = git+https://github.com/wolfSSL/wolfssl.git
- source = git+https://github.com/tcbrindle/span.git
source = git+https://github.com/zeux/pugixml.git
- source = git+https://github.com/madler/zlib.git
- source = git+https://github.com/curl/curl.git
- source = git+https://github.com/glennrp/libpng.git
- source = git+https://github.com/RPCS3/ffmpeg-core.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index be2ed6236d5e..701c04fb9f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=rpcs3
pkgver=0.0.18
-pkgrel=1
+pkgrel=2
pkgdesc='Open-source Sony PlayStation 3 Emulator'
arch=(x86_64)
url=https://rpcs3.net
@@ -13,7 +13,6 @@ makedepends=(cmake git libglvnd python vulkan-validation-layers)
options=(!emptydirs)
source=(
git+https://github.com/RPCS3/rpcs3.git#tag=v${pkgver}
- rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
@@ -26,12 +25,7 @@ source=(
git+https://github.com/asmjit/asmjit.git
git+https://github.com/libusb/libusb.git
git+https://github.com/wolfSSL/wolfssl.git
- git+https://github.com/tcbrindle/span.git
git+https://github.com/zeux/pugixml.git
- git+https://github.com/madler/zlib.git
- git+https://github.com/curl/curl.git
- git+https://github.com/glennrp/libpng.git
- git+https://github.com/RPCS3/ffmpeg-core.git
)
md5sums=('SKIP'
@@ -47,37 +41,26 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
prepare() {
cd "$pkgname"
- git submodule init
- git config submodule."rpcs3-ffmpeg".url ../ffmpeg-core
- git config submodule."3rdparty/cereal".url ../rpcs3-cereal
- git config submodule."3rdparty/hidapi".url ../rpcs3-hidapi
- git config submodule."llvm".url ../rpcs3-llvm
- git config submodule."3rdparty/yaml-cpp".url ../rpcs3-yaml-cpp
- git config submodule."3rdparty/xxHash".url ../xxHash
- git config submodule."3rdparty/FAudio".url ../FAudio
- git config submodule."3rdparty/flatbuffers".url ../flatbuffers
- git config submodule."3rdparty/glslang".url ../glslang
- git config submodule."3rdparty/SPIRV-Headers".url ../SPIRV-Headers
- git config submodule."3rdparty/SPIRV-Tools".url ../SPIRV-Tools
- git config submodule."asmjit".url ../asmjit
- git config submodule."3rdparty/libusb".url ../libusb
- git config submodule."3rdparty/wolfssl".url ../wolfssl
- git config submodule."3rdparty/span".url ../span
- git config submodule."3rdparty/pugixml".url ../pugixml
- git config submodule."3rdparty/zlib".url ../zlib
- git config submodule."3rdparty/curl".url ../curl
- git config submodule."3rdparty/libpng".url ../libpng
- git submodule update
+ git submodule init llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml}
+ echo $_args | xargs -n 1 -- git submodule init
+ git config submodule."3rdparty/hidapi".url "$srcdir"/rpcs3-hidapi
+ git config submodule."llvm".url "$srcdir"/rpcs3-llvm
+ git config submodule."3rdparty/yaml-cpp".url "$srcdir"/rpcs3-yaml-cpp
+ git config submodule."3rdparty/xxHash".url "$srcdir"/xxHash
+ git config submodule."3rdparty/FAudio".url "$srcdir"/FAudio
+ git config submodule."3rdparty/flatbuffers".url "$srcdir"/flatbuffers
+ git config submodule."3rdparty/glslang".url "$srcdir"/glslang
+ git config submodule."3rdparty/SPIRV-Headers".url "$srcdir"/SPIRV-Headers
+ git config submodule."3rdparty/SPIRV-Tools".url "$srcdir"/SPIRV-Tools
+ git config submodule."asmjit".url "$srcdir"/asmjit
+ git config submodule."3rdparty/libusb".url "$srcdir"/libusb
+ git config submodule."3rdparty/wolfssl".url "$srcdir"/wolfssl
+ git config submodule."3rdparty/pugixml".url "$srcdir"/pugixml
+ git submodule update llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml}
}
build() {