summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2021-06-30 17:40:47 -0700
committerChristopher Snowhill2021-06-30 17:40:47 -0700
commitac6931a0f2e930b317e27b3596892f4cf40f08fa (patch)
treeb205a78edbf32da66f184e0b3322531ddd573faa
parente9c42a959e1cc5f8922889e3309e9f5d5a180019 (diff)
downloadaur-ac6931a0f2e930b317e27b3596892f4cf40f08fa.tar.gz
upgpkg: rpcs3 0.0.17-1
Another release, another source management nightmare. I don't feel like dealing with this properly, so you get the bare minimum effort.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 28 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24ac4095ab89..f6593ad68c11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rpcs3
pkgdesc = Open-source Sony PlayStation 3 Emulator
- pkgver = 0.0.16
- pkgrel = 3
+ pkgver = 0.0.17
+ pkgrel = 1
url = https://rpcs3.net
arch = x86_64
license = GPL2
@@ -33,7 +33,7 @@ pkgbase = rpcs3
depends = zlib
depends = curl
options = !emptydirs
- source = git+https://github.com/RPCS3/rpcs3.git#tag=v0.0.16
+ source = git+https://github.com/RPCS3/rpcs3.git#tag=v0.0.17
source = rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
@@ -49,6 +49,14 @@ pkgbase = rpcs3
source = git+https://github.com/wolfSSL/wolfssl.git
source = git+https://github.com/tcbrindle/span.git
source = git+https://github.com/zeux/pugixml.git
+ source = git+https://github.com/madler/zlib.git
+ source = git+https://github.com/curl/curl.git
+ source = git+https://github.com/glennrp/libpng.git
+ source = git+https://github.com/RPCS3/ffmpeg-core.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 05b708ddf65c..79ebe7560ed2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: katt <magunasu.b97@gmail.com>
# Contributor: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=rpcs3
-pkgver=0.0.16
-pkgrel=3
+pkgver=0.0.17
+pkgrel=1
pkgdesc='Open-source Sony PlayStation 3 Emulator'
arch=(x86_64)
url=https://rpcs3.net
@@ -28,6 +28,10 @@ source=(
git+https://github.com/wolfSSL/wolfssl.git
git+https://github.com/tcbrindle/span.git
git+https://github.com/zeux/pugixml.git
+ git+https://github.com/madler/zlib.git
+ git+https://github.com/curl/curl.git
+ git+https://github.com/glennrp/libpng.git
+ git+https://github.com/RPCS3/ffmpeg-core.git
)
md5sums=('SKIP'
@@ -45,11 +49,16 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
cd "$pkgname"
git submodule init
+ git config submodule."rpcs3-ffmpeg".url ../ffmpeg-core
git config submodule."3rdparty/cereal".url ../rpcs3-cereal
git config submodule."3rdparty/hidapi".url ../rpcs3-hidapi
git config submodule."llvm".url ../rpcs3-llvm
@@ -57,14 +66,17 @@ prepare() {
git config submodule."3rdparty/xxHash".url ../xxHash
git config submodule."3rdparty/FAudio".url ../FAudio
git config submodule."3rdparty/flatbuffers".url ../flatbuffers
- git config submodule."Vulkan/glslang".url ../glslang
- git config submodule."Vulkan/spirv-headers".url ../SPIRV-Headers
- git config submodule."Vulkan/spirv-tools".url ../SPIRV-Tools
+ git config submodule."3rdparty/glslang".url ../glslang
+ git config submodule."3rdparty/SPIRV-Headers".url ../SPIRV-Headers
+ git config submodule."3rdparty/SPIRV-Tools".url ../SPIRV-Tools
git config submodule."asmjit".url ../asmjit
git config submodule."3rdparty/libusb".url ../libusb
git config submodule."3rdparty/wolfssl".url ../wolfssl
git config submodule."3rdparty/span".url ../span
git config submodule."3rdparty/pugixml".url ../pugixml
+ git config submodule."3rdparty/zlib".url ../zlib
+ git config submodule."3rdparty/curl".url ../curl
+ git config submodule."3rdparty/libpng".url ../libpng
git submodule update
}