summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2021-12-31 20:13:48 -0800
committerChristopher Snowhill2021-12-31 20:13:48 -0800
commitbb93c425fa31b1689a6e34f0e194344225ec80a2 (patch)
treeae6ad3cf261fec586d2f62f58556c7ac8c48bc16
parent52bb896719222aa4fad333449c8f2e71003245ad (diff)
downloadaur-bb93c425fa31b1689a6e34f0e194344225ec80a2.tar.gz
upgpkg: rpcs3 0.0.20-1
Updated package version, and added a new bundled dependency: mozilla/cubeb
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6de9ddd5ac7f..7ca1adb163be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpcs3
pkgdesc = Open-source Sony PlayStation 3 Emulator
- pkgver = 0.0.19
+ pkgver = 0.0.20
pkgrel = 1
url = https://rpcs3.net
arch = x86_64
@@ -35,7 +35,7 @@ pkgbase = rpcs3
depends = zlib
depends = curl
options = !emptydirs
- source = git+https://github.com/RPCS3/rpcs3.git#tag=v0.0.19
+ source = git+https://github.com/RPCS3/rpcs3.git#tag=v0.0.20
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
source = rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
@@ -49,6 +49,8 @@ pkgbase = rpcs3
source = git+https://github.com/libusb/libusb.git
source = git+https://github.com/wolfSSL/wolfssl.git
source = git+https://github.com/zeux/pugixml.git
+ source = git+https://github.com/mozilla/cubeb.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6490dc4c5c5a..01cd73d98cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: katt <magunasu.b97@gmail.com>
# Contributor: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=rpcs3
-pkgver=0.0.19
+pkgver=0.0.20
pkgrel=1
pkgdesc='Open-source Sony PlayStation 3 Emulator'
arch=(x86_64)
@@ -26,6 +26,7 @@ source=(
git+https://github.com/libusb/libusb.git
git+https://github.com/wolfSSL/wolfssl.git
git+https://github.com/zeux/pugixml.git
+ git+https://github.com/mozilla/cubeb.git
)
md5sums=('SKIP'
@@ -41,11 +42,12 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
cd "$pkgname"
- git submodule init llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml}
+ git submodule init llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml,cubeb/cubeb}
echo $_args | xargs -n 1 -- git submodule init
git config submodule."3rdparty/hidapi".url "$srcdir"/rpcs3-hidapi
git config submodule."llvm".url "$srcdir"/rpcs3-llvm
@@ -60,7 +62,8 @@ prepare() {
git config submodule."3rdparty/libusb".url "$srcdir"/libusb
git config submodule."3rdparty/wolfssl".url "$srcdir"/wolfssl
git config submodule."3rdparty/pugixml".url "$srcdir"/pugixml
- git submodule update llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml}
+ git config submodule."3rdparty/cubeb/cubeb".url "$srcdir"/cubeb
+ git submodule update llvm 3rdparty/{asmjit/asmjit,hidapi/hidapi,yaml-cpp/yaml-cpp,xxHash,FAudio,flatbuffers,glslang/glslang,SPIRV/SPIRV-{Headers,Tools},libusb/libusb,wolfssl,pugixml,cubeb/cubeb}
}
build() {