summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2020-01-03 15:37:47 +0100
committerSanpi2020-01-03 15:37:47 +0100
commitf3187cd027002ab23ff4508c0df4504f09c7b507 (patch)
treed3cc13d01ae91ad2f33ffb92d994016aba3e4fe9
parent07ad5efe0e54f8bbd7fbafbe60a861a282f92f7b (diff)
downloadaur-f3187cd027002ab23ff4508c0df4504f09c7b507.tar.gz
v0.0.8
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6a213cc1a9..e70b1192f0d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = rpcs3-bin
pkgdesc = Open-source Sony PlayStation 3 Emulator
- pkgver = 0.0.7
- pkgrel = 5
+ pkgver = 0.0.8
+ pkgrel = 1
url = https://rpcs3.net/
arch = x86_64
license = GPL2
makedepends = p7zip
- depends = ffmpeg
- depends = glew
depends = openal
depends = qt5-declarative
+ depends = glew
depends = vulkan-icd-loader
+ depends = hicolor-icon-theme
+ depends = libpulse
provides = rpcs3
conflicts = rpcs3
replaces = rpcs3
options = !strip
- source = https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-7475be99ab888ed38801e3a8e4565e81d9d8aa23/rpcs3-v0.0.7-9061-7475be99_linux64.AppImage
- sha256sums = ea5903de1ea651f4918ef83401d298800d71c2c7432263c637a774e4f8b30cb7
+ source = https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-b3ad89cc8bdbc3faaa1089e6e07dd11e937a2636/rpcs3-v0.0.8-9311-b3ad89cc_linux64.AppImage
+ sha256sums = 2cd0ce4fc310616c0343c5d27b01404e61a28811ca51fec3fa2e71dab49d4fe0
pkgname = rpcs3-bin
diff --git a/PKGBUILD b/PKGBUILD
index 76bf96197b59..ef7ff399aefb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=rpcs3-bin
-pkgver=0.0.7
-_pkgbuild='9061-7475be99'
-pkgrel=5
+pkgver=0.0.8
+_pkgbuild='9311-b3ad89cc'
+pkgrel=1
pkgdesc='Open-source Sony PlayStation 3 Emulator'
arch=('x86_64')
url='https://rpcs3.net/'
license=('GPL2')
-depends=('ffmpeg' 'glew' 'openal' 'qt5-declarative' 'vulkan-icd-loader')
+depends=(openal qt5-declarative glew vulkan-icd-loader hicolor-icon-theme libpulse)
makedepends=('p7zip')
options=('!strip')
replaces=('rpcs3')
provides=('rpcs3')
conflicts=('rpcs3')
-source=("https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-7475be99ab888ed38801e3a8e4565e81d9d8aa23/rpcs3-v$pkgver-${_pkgbuild}_linux64.AppImage")
-sha256sums=('ea5903de1ea651f4918ef83401d298800d71c2c7432263c637a774e4f8b30cb7')
+# curl --silent --dump-header - https://github.com/RPCS3/rpcs3-binaries-linux/releases/latest | grep '^Location: '
+_latest_release="https://github.com/RPCS3/rpcs3-binaries-linux/releases/download/build-b3ad89cc8bdbc3faaa1089e6e07dd11e937a2636"
+source=("${_latest_release}/rpcs3-v$pkgver-${_pkgbuild}_linux64.AppImage")
+sha256sums=('2cd0ce4fc310616c0343c5d27b01404e61a28811ca51fec3fa2e71dab49d4fe0')
prepare()
{
@@ -25,7 +27,7 @@ prepare()
package()
{
- cd "$srcdir"
+ cd "${srcdir}"
install -D -m755 'usr/bin/rpcs3' "$pkgdir/usr/bin/rpcs3"
install -D -m644 'usr/share/applications/rpcs3.desktop' "$pkgdir/usr/share/applications/rpcs3.desktop"