summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-10-29 14:23:57 +0100
committerMaxime Gauduin2017-10-29 14:23:57 +0100
commit18125b4d7fc134e93a89e57b410ad6b07fe8a17b (patch)
treedc3ecde1b9bb4ef8aa11223a6d0857bdc05bbb73
parentb80322c9b2c4dd47c1ef2ddbbc2d7677ececbd86 (diff)
downloadaur-18125b4d7fc134e93a89e57b410ad6b07fe8a17b.tar.gz
rpcs3-git-0.0.3.r510.c1f08ce58-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58c4ea848f19..7b8aac9e3fb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 8 22:25:17 UTC 2017
+# Sun Oct 29 13:23:54 UTC 2017
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.3.r101.e9b020bea
+ pkgver = 0.0.3.r510.c1f08ce58
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = rpcs3-git
makedepends = cereal
makedepends = cmake
makedepends = git
- makedepends = llvm
depends = alsa-lib
depends = gcc-libs
depends = glew
@@ -37,13 +36,13 @@ pkgbase = rpcs3-git
conflicts = rpcs3
source = git+https://github.com/RPCS3/rpcs3.git
source = rpcs3-common::git+https://github.com/RPCS3/common.git
- source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git#commit=c095a22
+ source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git#commit=ca39ce8
source = rpcs3-pugixml::git+https://github.com/RPCS3/pugixml.git#commit=f205aaf
- source = git+https://github.com/RPCS3/rsx-debugger.git#commit=3b11b96
- source = git+https://github.com/kobalicek/asmjit.git#commit=b0dad1a
+ source = git+https://github.com/kobalicek/asmjit.git#commit=1370fe6
source = git+https://github.com/Microsoft/GSL.git#commit=fc5fce4
- source = git+https://github.com/KhronosGroup/glslang.git#commit=2921e0c
- source = git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=64d375f
+ source = git+https://github.com/KhronosGroup/glslang.git#commit=cf571f7
+ source = git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=85926a3
+ source = git+https://github.com/akrzemi1/Optional.git#commit=f27e790
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b99aa98ad07c..9b82ab8187d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.3.r101.e9b020bea
+pkgver=0.0.3.r510.c1f08ce58
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=('x86_64')
@@ -11,18 +11,18 @@ depends=('alsa-lib' 'gcc-libs' 'glew' 'glibc' 'glu' 'libevdev' 'libgl' 'libpng'
'libx11' 'openal' 'qt5-base' 'vulkan-icd-loader' 'yaml-cpp' 'zlib'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libncursesw.so'
'libswresample.so' 'libswscale.so' 'libudev.so')
-makedepends=('boost' 'cereal' 'cmake' 'git' 'llvm')
+makedepends=('boost' 'cereal' 'cmake' 'git')
provides=('rpcs3')
conflicts=('rpcs3')
source=('git+https://github.com/RPCS3/rpcs3.git'
'rpcs3-common::git+https://github.com/RPCS3/common.git'
- 'rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git#commit=c095a22'
+ 'rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git#commit=ca39ce8'
'rpcs3-pugixml::git+https://github.com/RPCS3/pugixml.git#commit=f205aaf'
- 'git+https://github.com/RPCS3/rsx-debugger.git#commit=3b11b96'
- 'git+https://github.com/kobalicek/asmjit.git#commit=b0dad1a'
+ 'git+https://github.com/kobalicek/asmjit.git#commit=1370fe6'
'git+https://github.com/Microsoft/GSL.git#commit=fc5fce4'
- 'git+https://github.com/KhronosGroup/glslang.git#commit=2921e0c'
- 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=64d375f')
+ 'git+https://github.com/KhronosGroup/glslang.git#commit=cf571f7'
+ 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=85926a3'
+ 'git+https://github.com/akrzemi1/Optional.git#commit=f27e790')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -42,15 +42,15 @@ pkgver() {
prepare() {
pushd rpcs3
- git submodule init 3rdparty/{GSL,hidapi,pugixml} asmjit rsx-debugger Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
+ git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
git config submodule.asmjit.url ../asmjit
- git config submodule.hidapi.url ../rpcs3-hidapi
+ git config submodule.glslang.url ../glslang
git config submodule.GSL.url ../GSL
+ git config submodule.hidapi.url ../rpcs3-hidapi
+ git config submodule.Optional.url ../Optional
git config submodule.pugixml.url ../rpcs3-pugixml
- git config submodule.rsx-debugger.url ../rsx-debugger
- git config submodule.glslang.url ../glslang
git config submodule.Vulkan-LoaderAndValidationLayers ../Vulkan-LoaderAndValidationLayers
- git submodule update 3rdparty/{GSL,hidapi,pugixml} asmjit rsx-debugger Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
+ git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
popd