summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-06-04 19:53:25 +0200
committerMaxime Gauduin2018-06-04 19:53:25 +0200
commit3a330fe3ce041b36129af1520d83f3243ff4852a (patch)
treeedef87259f6517e345a581648fc9af5ed1c086e2
parent4a76dfb83dd5abcbd7d74c982e9a337035e64672 (diff)
downloadaur-3a330fe3ce041b36129af1520d83f3243ff4852a.tar.gz
Use upstream's modified llvm
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fd113e902cf..d56b293fa162 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed May 23 21:26:01 UTC 2018
+# Mon Jun 4 17:53:24 UTC 2018
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.5.r381.f38f61d11
+ pkgver = 0.0.5.r427.84ae64369
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
@@ -26,7 +26,6 @@ pkgbase = rpcs3-git
depends = libsm
depends = libx11
depends = libxext
- depends = llvm
depends = openal
depends = qt5-base
depends = qt5-declarative
@@ -45,6 +44,7 @@ pkgbase = rpcs3-git
source = git+https://github.com/RPCS3/rpcs3.git
source = rpcs3-common::git+https://github.com/RPCS3/common.git
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
+ source = rpcs3-llvm::git+https://github.com/RPCS3/llvm.git
source = git+https://github.com/kobalicek/asmjit.git
source = git+https://github.com/Microsoft/GSL.git
source = git+https://github.com/KhronosGroup/glslang.git
@@ -60,6 +60,7 @@ pkgbase = rpcs3-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = rpcs3-git
diff --git a/PKGBUILD b/PKGBUILD
index 7ead8d0e49ef..51f2db512752 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.5.r381.f38f61d11
+pkgver=0.0.5.r427.84ae64369
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=('x86_64')
url='https://github.com/RPCS3/rpcs3'
license=('GPL2')
depends=('alsa-lib' 'gcc-libs' 'glew' 'glibc' 'glu' 'libevdev' 'libgl' 'libice'
- 'libpng' 'libpulse' 'libsm' 'libx11' 'libxext' 'llvm' 'openal'
- 'qt5-base' 'qt5-declarative' 'vulkan-icd-loader' 'yaml-cpp' 'zlib'
+ 'libpng' 'libpulse' 'libsm' 'libx11' 'libxext' 'openal' 'qt5-base'
+ 'qt5-declarative' 'vulkan-icd-loader' 'yaml-cpp' 'zlib'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libncursesw.so'
'libswscale.so' 'libudev.so')
makedepends=('boost' 'cereal' 'cmake' 'ffmpeg' 'git'
@@ -20,7 +20,7 @@ options=('!emptydirs')
source=('git+https://github.com/RPCS3/rpcs3.git'
'rpcs3-common::git+https://github.com/RPCS3/common.git'
'rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git'
-# 'rpcs3-llvm::git+https://github.com/RPCS3/llvm.git'
+ 'rpcs3-llvm::git+https://github.com/RPCS3/llvm.git'
'git+https://github.com/kobalicek/asmjit.git'
'git+https://github.com/Microsoft/GSL.git'
'git+https://github.com/KhronosGroup/glslang.git'
@@ -35,6 +35,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -46,18 +47,16 @@ pkgver() {
prepare() {
pushd rpcs3
- git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit Vulkan/glslang
+ git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit llvm Vulkan/glslang
git config submodule.asmjit.url ../asmjit
git config submodule.glslang.url ../glslang
git config submodule.GSL.url ../GSL
git config submodule.hidapi.url ../rpcs3-hidapi
- #git config submodule.llvm.url ../rpcs3-llvm
+ git config submodule.llvm.url ../rpcs3-llvm
git config submodule.Optional.url ../Optional
git config submodule.pugixml.url ../pugixml
git config submodule.xxHash ../xxHash
- git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit Vulkan/glslang
-
- mkdir llvmlibs
+ git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit llvm Vulkan/glslang
popd