summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZion Nimchuk2020-03-28 20:59:31 -0700
committerZion Nimchuk2020-03-28 20:59:31 -0700
commit8be6f0bc09fb5b063c9acc325959450eb0907b33 (patch)
tree3eb572049216c9f7b4b2ca17f9485895b456348a
parentb2cbc11e18f91b6c8ffa798bb8082c6b567a3026 (diff)
downloadaur-8be6f0bc09fb5b063c9acc325959450eb0907b33.tar.gz
Make submodules be a blacklist, rather than a whitelist
This should make breakages happen less often, easing the maintence burden.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD42
2 files changed, 6 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49c4ef6c01e3..ebd8675fe547 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.9.r274.cba9ed352
+ pkgver = 0.0.9.r275.cc100f400
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
@@ -36,28 +36,6 @@ pkgbase = rpcs3-git
conflicts = rpcs3
options = !emptydirs
source = git+https://github.com/RPCS3/rpcs3.git
- source = rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
- source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
- source = rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
- source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
- source = rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
- source = git+https://github.com/kobalicek/asmjit.git
- source = git+https://github.com/FNA-XNA/FAudio.git
- source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/zeux/pugixml.git
- source = git+https://github.com/tcbrindle/span.git
- source = git+https://github.com/Cyan4973/xxHash.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = rpcs3-git
diff --git a/PKGBUILD b/PKGBUILD
index 3b88ab2b117e..f2fc03af2dfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Submitter: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.9.r274.cba9ed352
+pkgver=0.0.9.r275.cc100f400
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=(x86_64)
@@ -44,31 +44,9 @@ conflicts=(rpcs3)
options=(!emptydirs)
source=(
git+https://github.com/RPCS3/rpcs3.git
- rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
- rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
- rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
- rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
- rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
- git+https://github.com/kobalicek/asmjit.git
- git+https://github.com/FNA-XNA/FAudio.git
- git+https://github.com/KhronosGroup/glslang.git
- git+https://github.com/zeux/pugixml.git
- git+https://github.com/tcbrindle/span.git
- git+https://github.com/Cyan4973/xxHash.git
)
sha256sums=(
SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
)
pkgver() {
@@ -79,20 +57,10 @@ pkgver() {
prepare() {
cd rpcs3
-
- git submodule init 3rdparty/{cereal,FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
- git config submodule.asmjit.url ../asmjit
- git config submodule.cereal.url ../rpcs3-cereal
- git config submodule.glslang.url ../glslang
- git config submodule.FAudio.url ../FAudio
- git config submodule.hidapi.url ../rpcs3-hidapi
- git config submodule.libusb.url ../rpcs3-libusb
- git config submodule.llvm.url ../rpcs3-llvm
- git config submodule.pugixml.url ../pugixml
- git config submodule.span.url ../span
- git config submodule.xxHash ../xxHash
- git config submodule.yaml-cpp ../rpcs3-yaml-cpp
- git submodule update 3rdparty/{cereal,FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
+
+ SUBMODULES=$(git config --file .gitmodules --get-regexp path | awk '!/ffmpeg/ && !/libpng/ && !/zlib/ && !/curl/ && !/wolfssl/ { print $2 }')
+
+ git submodule update --init $SUBMODULES
}
build() {