summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2020-03-22 21:05:20 +0100
committerMaxime Gauduin2020-03-22 21:05:20 +0100
commitc766a9450b39463609d0d80e1824593a77cf58b0 (patch)
tree1845834474a7668375d02d7abf1ef9cdd80025a7
parente81b8aa40134c713ebbdcb246f719009281a04df (diff)
downloadaur-c766a9450b39463609d0d80e1824593a77cf58b0.tar.gz
updates
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fdc01a37a60..6a9927096a38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.9.r140.33d01fd25
+ pkgver = 0.0.9.r201.b447e6f55
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
@@ -36,9 +36,11 @@ pkgbase = rpcs3-git
options = !emptydirs
source = git+https://github.com/RPCS3/rpcs3.git
source = rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
+ source = rpcs3-curl::git+https://github.com/RipleyTom/curl.git
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
source = rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
+ source = rpcs3-wolfssl::git+https://github.com/RipleyTom/wolfssl.git
source = rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
source = git+https://github.com/kobalicek/asmjit.git
source = git+https://github.com/FNA-XNA/FAudio.git
@@ -58,6 +60,8 @@ pkgbase = rpcs3-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = rpcs3-git
diff --git a/PKGBUILD b/PKGBUILD
index d1ca666d2626..c6bceabe619c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.9.r140.33d01fd25
+pkgver=0.0.9.r201.b447e6f55
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=(x86_64)
@@ -43,9 +43,11 @@ options=(!emptydirs)
source=(
git+https://github.com/RPCS3/rpcs3.git
rpcs3-cereal::git+https://github.com/RPCS3/cereal.git
+ rpcs3-curl::git+https://github.com/RipleyTom/curl.git
rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
+ rpcs3-wolfssl::git+https://github.com/RipleyTom/wolfssl.git
rpcs3-yaml-cpp::git+https://github.com/RPCS3/yaml-cpp.git
git+https://github.com/kobalicek/asmjit.git
git+https://github.com/FNA-XNA/FAudio.git
@@ -67,6 +69,8 @@ sha256sums=(
SKIP
SKIP
SKIP
+ SKIP
+ SKIP
)
pkgver() {
@@ -78,9 +82,10 @@ pkgver() {
prepare() {
cd rpcs3
- git submodule init 3rdparty/{cereal,FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
+ git submodule init 3rdparty/{cereal,curl,FAudio,hidapi,libusb,pugixml,span,wolfssl,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
git config submodule.asmjit.url ../asmjit
git config submodule.cereal.url ../rpcs3-cereal
+ git config submodule.cereal.url ../rpcs3-curl
git config submodule.glslang.url ../glslang
git config submodule.FAudio.url ../FAudio
git config submodule.hidapi.url ../rpcs3-hidapi
@@ -88,9 +93,10 @@ prepare() {
git config submodule.llvm.url ../rpcs3-llvm
git config submodule.pugixml.url ../pugixml
git config submodule.span.url ../span
+ git config submodule.yaml-cpp ../rpcs3-wolfssl
git config submodule.xxHash ../xxHash
git config submodule.yaml-cpp ../rpcs3-yaml-cpp
- git submodule update 3rdparty/{cereal,FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
+ git submodule update 3rdparty/{cereal,curl,FAudio,hidapi,libusb,pugixml,span,wolfssl,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
}
build() {