summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2020-03-04 10:58:34 +0100
committerMaxime Gauduin2020-03-04 10:58:34 +0100
commiteeb72cc766f2764c401fe8d23751b02d794dec71 (patch)
tree24fcde14fa9e69cab7d9f9ebcd5e3c162f4c0b6a
parent5e7df81bbc265dd49e032b9bff9ba1bb92344a9b (diff)
downloadaur-eeb72cc766f2764c401fe8d23751b02d794dec71.tar.gz
updates
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
2 files changed, 24 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02c025e9c307..c312d426a61b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,37 @@
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.8.r424.df1813b4e
+ pkgver = 0.0.9.r22.8d847d6f1
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
license = GPL2
- makedepends = boost
makedepends = cereal
makedepends = cmake
- makedepends = ffmpeg
makedepends = git
makedepends = libglvnd
makedepends = python
makedepends = vulkan-validation-layers
- makedepends = xorgproto
depends = alsa-lib
- depends = faudio
depends = glew
depends = glu
+ depends = libavcodec.so
+ depends = libavutil.so
depends = libevdev
depends = libgl
depends = libice
+ depends = libncursesw.so
depends = libpng
depends = libpulse
depends = libsm
+ depends = libswscale.so
depends = libx11
depends = libxext
depends = openal
depends = qt5-base
depends = qt5-declarative
+ depends = sdl2
depends = vulkan-icd-loader
depends = zlib
- depends = libavcodec.so
- depends = libavformat.so
- depends = libavutil.so
- depends = libncursesw.so
- depends = libswscale.so
- depends = libudev.so
- depends = libz3.so
provides = rpcs3
conflicts = rpcs3
options = !emptydirs
@@ -45,7 +39,7 @@ pkgbase = rpcs3-git
source = rpcs3-common::git+https://github.com/RPCS3/common.git
source = rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
source = rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
- source = rpcs3-llvm::git+https://github.com/RPCS3/llvm.git
+ source = rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
source = git+https://github.com/kobalicek/asmjit.git
source = git+https://github.com/FNA-XNA/FAudio.git
source = git+https://github.com/KhronosGroup/glslang.git
diff --git a/PKGBUILD b/PKGBUILD
index ef3fbc8b5d40..67475dbb77fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.8.r424.df1813b4e
+pkgver=0.0.9.r22.8d847d6f1
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=(x86_64)
@@ -9,40 +9,34 @@ url=https://github.com/RPCS3/rpcs3
license=(GPL2)
depends=(
alsa-lib
- faudio
glew
glu
+ libavcodec.so
+ libavutil.so
libevdev
libgl
libice
+ libncursesw.so
libpng
libpulse
libsm
+ libswscale.so
libx11
libxext
openal
qt5-base
qt5-declarative
+ sdl2
vulkan-icd-loader
zlib
- libavcodec.so
- libavformat.so
- libavutil.so
- libncursesw.so
- libswscale.so
- libudev.so
- libz3.so
)
makedepends=(
- boost
cereal
cmake
- ffmpeg
git
libglvnd
python
vulkan-validation-layers
- xorgproto
)
provides=(rpcs3)
conflicts=(rpcs3)
@@ -52,7 +46,7 @@ source=(
rpcs3-common::git+https://github.com/RPCS3/common.git
rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git
rpcs3-libusb::git+https://github.com/RPCS3/libusb.git
- rpcs3-llvm::git+https://github.com/RPCS3/llvm.git
+ rpcs3-llvm::git+https://github.com/RPCS3/llvm-mirror.git
git+https://github.com/kobalicek/asmjit.git
git+https://github.com/FNA-XNA/FAudio.git
git+https://github.com/KhronosGroup/glslang.git
@@ -83,7 +77,7 @@ pkgver() {
}
prepare() {
- pushd rpcs3
+ cd rpcs3
git submodule init 3rdparty/{FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
git config submodule.asmjit.url ../asmjit
@@ -97,26 +91,18 @@ prepare() {
git config submodule.xxHash ../xxHash
git config submodule.yaml-cpp ../yaml-cpp
git submodule update 3rdparty/{FAudio,hidapi,libusb,pugixml,span,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
-
- popd
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
}
build() {
- cd build
-
- cmake ../rpcs3 \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_SKIP_RPATH='ON' \
- -DUSE_SYSTEM_FFMPEG='ON' \
- -DUSE_SYSTEM_LIBPNG='ON' \
- -DUSE_NATIVE_INSTRUCTIONS='OFF'
- make
+ cmake -S rpcs3 -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DUSE_NATIVE_INSTRUCTIONS=OFF \
+ -DUSE_SYSTEM_FFMPEG=ON \
+ -DUSE_SYSTEM_LIBPNG=ON \
+ -DUSE_SYSTEM_ZLIB=ON
+ make -C build
}
package() {