summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-10-03 20:27:44 +0200
committerCarsten Teibes2017-10-03 20:37:01 +0200
commitf9789349f095124bc3321e0a19f164b06df9819b (patch)
treec5d29a81eb67a5ffd7d2b4e5d05f64ed652acc54
downloadaur-f9789349f095124bc3321e0a19f164b06df9819b.tar.gz
[add] rpg2000-rtp 2000
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--rpg2000-rtp.sh10
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0ca193afa18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rpg2000-rtp
+ pkgdesc = RPG Maker 2000 Runtime Package (Japanese)
+ pkgver = 2000
+ pkgrel = 1
+ url = https://tkool.jp/support/download/rpg2000/rtp
+ arch = any
+ license = custom: commercial
+ makedepends = unshield-git
+ makedepends = convmv
+ makedepends = glibc
+ optdepends = easyrpg-player: game engine for using the RTP
+ noextract = 2000rtp.zip
+ source = https://tkool.jp/assets/files/2000rtp.zip
+ source = rpg2000-rtp.sh
+ sha256sums = c130f0078c0d6ecc3404f94af8258e4557ab85c3b204397c7f21dbc57efeef8e
+ sha256sums = 1a892b64ea2df5827e560100408d6ff3f8abc9ec008f62bc8167fb91c0c2b5da
+
+pkgname = rpg2000-rtp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d88ca44ac4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=rpg2000-rtp
+pkgver=2000
+pkgrel=1
+pkgdesc="RPG Maker 2000 Runtime Package (Japanese)"
+arch=('any')
+url="https://tkool.jp/support/download/rpg2000/rtp"
+license=('custom: commercial')
+makedepends=('unshield-git' 'convmv' 'glibc')
+optdepends=('easyrpg-player: game engine for using the RTP')
+source=("https://tkool.jp/assets/files/2000rtp.zip"
+ "$pkgname.sh")
+sha256sums=('c130f0078c0d6ecc3404f94af8258e4557ab85c3b204397c7f21dbc57efeef8e'
+ '1a892b64ea2df5827e560100408d6ff3f8abc9ec008f62bc8167fb91c0c2b5da')
+noextract=('2000rtp.zip')
+
+prepare() {
+ # extract
+ bsdtar --strip-components 1 --include='*.exe' -xf 2000rtp.zip
+ bsdtar --include='*.txt' -O -xf 2000rtp.zip > TOS-sjis.txt
+ bsdtar -xf RPG2000RTP.exe
+ unshield -R -d rtp x data1.cab
+ # cleanup
+ rm -rf rtp/_*
+ convmv -f SHIFT-JIS -t UTF-8 -r --qfrom --notest rtp
+ iconv -f SHIFT-JIS -t UTF-8 TOS-sjis.txt > TOS.txt
+ mv rtp/"RPGツクール2000_ランタイムパッケージ" 2000
+}
+
+package() {
+ # data
+ install -Dm0644 2000/RPG2000.ico "$pkgdir"/usr/share/rtp/RPG2000.ico
+ cp -r 2000/RTP "$pkgdir"/usr/share/rtp/2000
+ # sane permissions
+ find "$pkgdir"/usr/share/rtp -type d -exec chmod 0755 {} \;
+ find "$pkgdir"/usr/share/rtp -type f -exec chmod 0644 {} \;
+ # export environment variables
+ install -Dm0755 $pkgname.sh "$pkgdir"/etc/profile.d/$pkgname.sh
+ # license
+ install -Dm0644 TOS.txt "$pkgdir"/usr/share/licenses/$pkgname/TOS.txt
+}
diff --git a/rpg2000-rtp.sh b/rpg2000-rtp.sh
new file mode 100644
index 000000000000..49909e79e4b3
--- /dev/null
+++ b/rpg2000-rtp.sh
@@ -0,0 +1,10 @@
+RTP=/usr/share/rtp/2000
+
+if [ -z "$RPG2K_RTP_PATH" ]; then
+ RPG2K_RTP_PATH=$RTP
+else
+ # add to end of path list
+ RPG2K_RTP_PATH=${RPG2K_RTP_PATH}:$RTP
+fi
+
+export RPG2K_RTP_PATH