summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjikstra2019-05-20 22:05:12 +0200
committerjikstra2019-05-20 22:05:12 +0200
commitb445423f39588e1f684deee1b960a1457d5d8c67 (patch)
tree10dd4c83e47361e2b3999ab978d88a3ff5e342e2
downloadaur-b445423f39588e1f684deee1b960a1457d5d8c67.tar.gz
Added PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b2361e0c714
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rpgp-git
+ pkgdesc = Pure rust implementation of OpenPGP
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/deltachat/deltachat-desktop
+ arch = any
+ license = APACHE
+ license = MIT
+ makedepends = rustup
+ depends = gcc-libs
+
+pkgname = rpgp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4e2bb591ba95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jikstra <jikstra@disroot.org>
+pkgname=rpgp-git
+pkgdesc="Pure rust implementation of OpenPGP "
+pkgver=0.2.0
+pkgrel=1
+_gittag="v${pkgver}-alpha"
+arch=('any')
+url="https://github.com/deltachat/deltachat-desktop"
+license=('APACHE' 'MIT')
+depends=('gcc-libs')
+makedepends=('rustup')
+
+prepare() {
+ cd "$srcdir"
+ git clone --branch $_gittag --depth 1 https://github.com/rpgp/rpgp.git $pkgname
+}
+
+build() {
+ cd "$pkgname/pgp-ffi"
+ echo "Active rust toolchain: $(rustup show active-toolchain)"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ install -d "${pkgdir}/usr/lib/"
+ install -m 644 "target/release/libpgp_ffi.so" "${pkgdir}/usr/lib/librpgp.so"
+ install -d "${pkgdir}/usr/include/"
+ install -m 644 "pgp-ffi/librpgp.h" "${pkgdir}/usr/include/"
+ install -d "${pkgdir}/usr/lib/pkgconfig"
+ install -m 644 "target/release/pkgconfig/rpgp.pc" "${pkgdir}/usr/lib/pkgconfig"
+}
+