summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-27 18:16:39 +0800
committermaz-12015-10-27 18:16:39 +0800
commit6a08667cef71c8ed28cbc2d2556b72a9c8ca9aec (patch)
treedb99dae056b821224aef3fd67dcfbe9d13434bfe
downloadaur-6a08667cef71c8ed28cbc2d2556b72a9c8ca9aec.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD24
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3eee3c12a10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rpgvx-rtp
+ pkgdesc = RPGMaker Runtime Package
+ pkgver = 202
+ pkgrel = 1
+ url = http://www.rpgmakerweb.com/download/additional/run-time-packages
+ arch = any
+ license = custom: commercial
+ makedepends = libarchive
+ makedepends = innoextract
+ makedepends = convmv
+ noextract = vx_rtp202.zip
+ source = http://tkool.jp/assets/files/vx_rtp202.zip
+ source = LICENSE
+ md5sums = 9d5377c02400491f96adcf9f429b9b8e
+ md5sums = 01fee4ed0a5af011bd5b16e54f80e511
+
+pkgname = rpgvx-rtp
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..640f2ceb18d2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+RPG MAKER VX Ace Runtime Package - End User License Agreement (Mar. 15th, 2012)
+
+THIS END USER LICENSE AGREEMENT (THE "AGREEMENT") IS A LEGALLY BINDING CONTRACT BETWEEN YOU, THE END-USER (THE "LICENSEE") AND ENTERBRAIN,INC. ("ENTERBRAIN" OR "LICENSOR"). BY INSTALLING OR USING "RPG MAKER VX ACE RUNTIME PACKAGE" (THE "RTP SOFTWARE"), YOU, THE LICENSEE, ARE AGREEING TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS AGREEMENT. READ THE TERMS AND CONDITIONS OF THIS AGREEMENT CAREFULLY BEFORE INSTALLING OR USING THE RTP SOFTWARE. IF YOU DO NOT AGREE TO THE TERMS, CONDITIONS AND LIMITATIONS OF THIS AGREEMENT, PROMPTLY DELETE THE RTP SOFTWARE FROM YOUR COMPUTER.
+
+ ENTERBRAIN grants to Licensee a non-exclusive, non-assignable, fee-free license to use the RTP SOFTWARE only for the purpose to play the game created and distributed by RPG MAKER VX Ace users who shall complete the registration procedure.
+
+ Licensee shall not reverse engineer, de-compile, or disassemble the RTP SOFTWARE. Further, Licensee shall not sell, distribute, assign, lease, sublicense, encumber, or otherwise transfer the RTP SOFTWARE and/or its data without any prior written consent of ENTERBRAIN.
+
+ This Agreement and the license granted hereunder automatically terminates if Licensee breaches any provision of this Agreement. Immediately upon termination of this Agreement, Licensee shall cease using the RTP SOFTWARE, shall delete the RTP SOFTWARE from its computers and shall either return to ENTERBRAIN or destroy the RTP SOFTWARE. If Licensee elects to destroy the RTP SOFTWARE, then Licensee shall certify in writing to ENTERBRAIN the destruction of the RTP SOFTWARE.
+
+ ENTERBRAIN does not warrant that the RTP SOFTWARE will meet Licensee's requirements, that the RTP SOFTWARE will operate in combinations other than as specified in the Documentation, that the operation of the RTP SOFTWARE will be uninterrupted or error-free or that RTP SOFTWARE errors will be corrected. ENTERBRAIN HEREBY DISCLAIMS ANY AND ALL REPRESENTATION AND WARRANTIES IN ANY MANNER, WHETHER EXPRESS OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+
+ IN NO EVENT SHALL ENTERBRAIN BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL, PUNITIVE OR CONSEQUENTIAL DAMAGES, OR DAMAGES FOR LOSS OF PROFITS, REVENUE, DATA OR USE, INCURRED BY LICENSEE OR ANY THIRD PARTY, WHETHER IN AN ACTION IN CONTRACT OR TORT, EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. ENTERBRAIN'S LIABILITY FOR DAMAGES AND EXPENSES HEREUNDER OR RELATING HERETO (WHETHER IN AN ACTION IN CONTRACT OR TORT) WILL IN NO EVENT EXCEED THE AMOUNT OF LICENSE FEES PAID TO ENTERBRAIN WITH RESPECT TO THIS AGREEMENT.
+
+ This Agreement constitutes the complete agreement between the parties and supersedes all prior or contemporaneous agreements or representations, written or oral, concerning the subject matter of this Agreement.
+
+ This Agreement will be interpreted and enforced in accordance with the laws of Japan without regard to choice of law principles. Any and all dispute arising out of or in connection with this Agreement shall solely be resolved by and at Tokyo District court, Tokyo, Japan.
+
+Note for using VX Ace RTP with other RPG MAKER products.
+
+The materials included in RPG MAKER VX Ace RTP can be used with other RPG MAKER products from Enterbrain as long as you own both RPG MAKER VX Ace and other RPG MAKER products. For example, if you already own RPG MAKER VX and you want to use any materials included in the VX Ace RTP with RPG MAKER VX, you need to purchase and own RPG MAKER VX Ace also.
+
+(C) 2012 ENTERBRAIN, INC./YOJI OJIMA
+
+Microsoft(R), Windows(R), Windows Vista(R), DirectX(R) are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.
+
+All other trademarks or registered trademarks are the property of their respective owners. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c228b133b599
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
+pkgname=rpgvx-rtp
+pkgver=202
+pkgrel=1
+pkgdesc="RPGMaker Runtime Package"
+url='http://www.rpgmakerweb.com/download/additional/run-time-packages'
+arch=('any')
+license=('custom: commercial')
+makedepends=('libarchive' 'innoextract' 'convmv')
+source=("http://tkool.jp/assets/files/vx_rtp$pkgver.zip" "LICENSE")
+md5sums=('9d5377c02400491f96adcf9f429b9b8e' '01fee4ed0a5af011bd5b16e54f80e511')
+noextract=vx_rtp202.zip
+
+package() {
+ cd "$srcdir"
+ bsdtar xf vx_rtp$pkgver.zip
+ cd RPGVX_RTP$pkgver
+ #find . | iconv -f SHIFT-JIS -t utf-8
+ convmv -r -f SHIFT-JIS -t utf-8 --notest .
+ innoextract setup.exe
+ mkdir -p "$pkgdir/opt/"
+ cp -r app "$pkgdir/opt/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/opt/$pkgname/LICENSE"
+}