summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-29 14:54:33 +0800
committermaz-12015-10-29 14:54:33 +0800
commit87dfacfa379e35a035901dccdd3ac89c530f7514 (patch)
treeaccf01ac981a709754664947f84afa9bf1f6d8c2
downloadaur-87dfacfa379e35a035901dccdd3ac89c530f7514.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD25
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5198a02b9793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rpgxp-rtp
+ pkgdesc = RPGMaker XP Runtime Package
+ pkgver = 103
+ pkgrel = 1
+ url = http://www.rpgmakerweb.com/download/additional/run-time-packages
+ arch = any
+ license = custom: commercial
+ makedepends = libarchive
+ makedepends = innoextract
+ makedepends = convmv
+ noextract = xp_rtp103.zip
+ source = http://tkool.jp/assets/files/xp_rtp103.zip
+ source = LICENSE
+ md5sums = 3a4a0f3615f536e29b4b1cf33ee58742
+ md5sums = fb08af026ac58b13ee582a447575cf42
+
+pkgname = rpgxp-rtp
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d9e2e446f7ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+RPG MAKER XP Runtime Package - End User License Agreement (Mar. 15th, 2012)
+
+THIS END USER LICENSE AGREEMENT (THE "AGREEMENT") IS A LEGALLY BINDING CONTRACT BETWEEN YOU, THE END-USER (THE "LICENSEE") AND ENTERBRAIN,INC. ("ENTERBRAIN" OR "LICENSOR"). BY INSTALLING OR USING "RPG MAKER XP RUNTIME PACKAGE" (THE "RTP SOFTWARE"), YOU, THE LICENSEE, ARE AGREEING TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS AGREEMENT. READ THE TERMS AND CONDITIONS OF THIS AGREEMENT CAREFULLY BEFORE INSTALLING OR USING THE RTP SOFTWARE. IF YOU DO NOT AGREE TO THE TERMS, CONDITIONS AND LIMITATIONS OF THIS AGREEMENT, PROMPTLY DELETE THE RTP SOFTWARE FROM YOUR COMPUTER.
+
+ ENTERBRAIN grants to Licensee a non-exclusive, non-assignable, fee-free license to use the RTP SOFTWARE only for the purpose to play the game created and distributed by RPG MAKER XP users who shall complete the registration procedure.
+
+ Licensee shall not reverse engineer, de-compile, or disassemble the RTP SOFTWARE. Further, Licensee shall not sell, distribute, assign, lease, sublicense, encumber, or otherwise transfer the RTP SOFTWARE and/or its data without any prior written consent of ENTERBRAIN.
+
+ This Agreement and the license granted hereunder automatically terminates if Licensee breaches any provision of this Agreement. Immediately upon termination of this Agreement, Licensee shall cease using the RTP SOFTWARE, shall delete the RTP SOFTWARE from its computers and shall either return to ENTERBRAIN or destroy the RTP SOFTWARE. If Licensee elects to destroy the RTP SOFTWARE, then Licensee shall certify in writing to ENTERBRAIN the destruction of the RTP SOFTWARE.
+
+ ENTERBRAIN does not warrant that the RTP SOFTWARE will meet Licensee's requirements, that the RTP SOFTWARE will operate in combinations other than as specified in the Documentation, that the operation of the RTP SOFTWARE will be uninterrupted or error-free or that RTP SOFTWARE errors will be corrected. ENTERBRAIN HEREBY DISCLAIMS ANY AND ALL REPRESENTATION AND WARRANTIES IN ANY MANNER, WHETHER EXPRESS OR IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+
+ IN NO EVENT SHALL ENTERBRAIN BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL, PUNITIVE OR CONSEQUENTIAL DAMAGES, OR DAMAGES FOR LOSS OF PROFITS, REVENUE, DATA OR USE, INCURRED BY LICENSEE OR ANY THIRD PARTY, WHETHER IN AN ACTION IN CONTRACT OR TORT, EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. ENTERBRAIN'S LIABILITY FOR DAMAGES AND EXPENSES HEREUNDER OR RELATING HERETO (WHETHER IN AN ACTION IN CONTRACT OR TORT) WILL IN NO EVENT EXCEED THE AMOUNT OF LICENSE FEES PAID TO ENTERBRAIN WITH RESPECT TO THIS AGREEMENT.
+
+ This Agreement constitutes the complete agreement between the parties and supersedes all prior or contemporaneous agreements or representations, written or oral, concerning the subject matter of this Agreement.
+
+ This Agreement will be interpreted and enforced in accordance with the laws of Japan without regard to choice of law principles. Any and all dispute arising out of or in connection with this Agreement shall solely be resolved by and at Tokyo District court, Tokyo, Japan.
+
+Note for using XP RTP with other RPG MAKER products.
+
+The materials included in RPG MAKER XP RTP can be used with other RPG MAKER products from Enterbrain as long as you own both RPG MAKER XP and other RPG MAKER products. For example, if you already own RPG MAKER VX and you want to use any materials included in the XP RTP with RPG MAKER VX, you need to purchase and own RPG MAKER XP also.
+
+(C) 2012 ENTERBRAIN, INC./YOJI OJIMA
+
+Microsoft(R), Windows(R), Windows Vista(R), DirectX(R) are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.
+
+All other trademarks or registered trademarks are the property of their respective owners. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac4ce2e7ce51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
+pkgname=rpgxp-rtp
+pkgver=103
+pkgrel=1
+pkgdesc="RPGMaker XP Runtime Package"
+url='http://www.rpgmakerweb.com/download/additional/run-time-packages'
+arch=('any')
+license=('custom: commercial')
+makedepends=('libarchive' 'innoextract' 'convmv')
+source=("http://tkool.jp/assets/files/xp_rtp$pkgver.zip" "LICENSE")
+md5sums=('3a4a0f3615f536e29b4b1cf33ee58742' 'fb08af026ac58b13ee582a447575cf42')
+noextract=xp_rtp$pkgver.zip
+
+package() {
+ cd "$srcdir"
+ bsdtar xf xp_rtp$pkgver.zip
+ cd RPGXP_RTP$pkgver
+ innoextract Setup.exe
+ convmv -r -f SHIFT-JIS -t utf-8 --notest .
+ mkdir -p "$pkgdir/opt/"
+ cp -r app "$pkgdir/opt/$pkgname"
+ cp sys/*.dll "$pkgdir/opt/$pkgname"
+ cp "利用規約.txt" "$pkgdir/opt/$pkgname"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/opt/$pkgname/LICENSE"
+}