summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin lyons2017-08-14 16:40:46 +0100
committerGavin lyons2017-08-14 16:40:46 +0100
commitdc3d29bf03d68096900ddb781faf7a80466073f8 (patch)
tree39f4452d031238b9d226d58320e6cdd8679d2fce
downloadaur-dc3d29bf03d68096900ddb781faf7a80466073f8.tar.gz
First commit to AUR Version 1.3-4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a477737dfdeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rpi_tempmon
+ pkgdesc = Raspberry pi ARM, CPU GPU temperature monitor with various functions, Bash and python
+ pkgver = 1.3
+ pkgrel = 4
+ url = https://github.com/gavinlyonsrepo/raspberrypi_tempmon
+ arch = any
+ license = GPL
+ optdepends = ssmtp
+ optdepends = python-matplotlib
+ source = https://github.com/gavinlyonsrepo/raspberrypi_tempmon/archive/1.3.tar.gz
+ md5sums = 7e41ee0d5a6beaad3ac2a5ddd5a6ec26
+
+pkgname = rpi_tempmon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a36f6df0ee8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: gavin lyons <glyons66@hotmail.com>
+# https://github.com/gavinlyonsrepo/raspberrypi_tempmon
+pkgname=rpi_tempmon
+pkgver=1.3
+pkgrel=4
+pkgdesc="Raspberry pi ARM, CPU GPU temperature monitor with various functions, Bash and python"
+depends=()
+arch=('any')
+url="https://github.com/gavinlyonsrepo/raspberrypi_tempmon"
+license=('GPL')
+optdepends=('ssmtp' 'python-matplotlib')
+source=("https://github.com/gavinlyonsrepo/raspberrypi_tempmon/archive/$pkgver.tar.gz")
+
+md5sums=('7e41ee0d5a6beaad3ac2a5ddd5a6ec26')
+package() {
+ cd "$srcdir/raspberrypi_tempmon-${pkgver}"
+ install -D -m755 src/rpi_tempmon.sh "$pkgdir"/usr/bin/"${pkgname}"
+
+ install -d "$pkgdir"/usr/lib/rpi_tempmon/
+ install -D -m755 modules/* "$pkgdir"/usr/lib/rpi_tempmon
+}