summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Woodbine2018-06-08 21:30:15 +1200
committerCaleb Woodbine2018-06-08 21:30:15 +1200
commit5e69a11a5ffae9bc5e4cebb35d86259f4038cf59 (patch)
treea774e2d8f7e0a501b47a460d3635eac34d5114ec
downloadaur-5e69a11a5ffae9bc5e4cebb35d86259f4038cf59.tar.gz
rpicustomiser inital commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5af761798b3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rpicustomiser
+ pkgdesc = A useful tool for customising Rasbian. Chroot, install deb packages, copy files, customise.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://gitlab.com/BobyMCbobs/
+ arch = any
+ license = GPL
+ depends = bash
+ depends = qemu
+ depends = qemu-user-static
+ depends = binfmt-support
+ source = https://gitlab.com/BobyMCbobs/rpicustomiser/-/archive/1.0.1/rpicustomiser-1.0.1.zip
+ md5sums = SKIP
+
+pkgname = rpicustomiser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aea890de5619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Caleb Woodbine <github.com/BobyMCbobs>
+pkgname=rpicustomiser
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A useful tool for customising Rasbian. Chroot, install deb packages, copy files, customise."
+arch=('any')
+url="https://gitlab.com/BobyMCbobs/${rpicustomiser}"
+license=('GPL')
+depends=('bash' 'qemu' 'qemu-user-static' 'binfmt-support')
+install=
+source=("https://gitlab.com/BobyMCbobs/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.zip")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}