summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2018-11-20 00:55:29 +0100
committerUffe Jakobsen2018-11-20 00:55:29 +0100
commit1abe26dc0cb3f323eeb44f5a33943204388df9ec (patch)
treed1f1013c329b2b417abc5cbb40e5838d5d899062
downloadaur-1abe26dc0cb3f323eeb44f5a33943204388df9ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..583c2ba70021
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Nov 19 23:53:45 UTC 2018
+pkgbase = rpiusbboot-git
+ pkgdesc = Raspberry Pi USB boot
+ pkgver = r67.fcadec3
+ pkgrel = 1
+ url = https://github.com/raspberrypi/usbboot
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = libusb
+ source = git+https://github.com/raspberrypi/usbboot.git
+ md5sums = SKIP
+
+pkgname = rpiusbboot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc8803d965ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#
+# Maintainer: Uffe Jakobsen <uffe@uffe.org>
+#
+
+pkgname=rpiusbboot-git
+_pkgname=usbboot
+pkgver=r67.fcadec3
+pkgrel=1
+pkgdesc="Raspberry Pi USB boot"
+arch=("i686" "x86_64")
+url="https://github.com/raspberrypi/usbboot"
+license=("Apache")
+depends=("libusb")
+conflict=()
+source=("git+https://github.com/raspberrypi/usbboot.git")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ #make DESTDIR="${pkgdir}/" install
+ install -D rpiboot ${pkgdir}/usr/bin/rpiusbboot
+}
+
+#
+# EOF
+#