summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2015-06-08 23:18:10 -0600
committeramagura2015-06-08 23:18:10 -0600
commit018e2885a0facbf7c511b6f8d3c467ac26954fc5 (patch)
tree631f24c6c376fae4ddf3c4635630529c98fc154c
downloadaur-018e2885a0facbf7c511b6f8d3c467ac26954fc5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD36
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec2b6ed0ab2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rpl
+ pkgdesc = UN*X text replacement utility
+ pkgver = 1.4.1
+ pkgrel = 13
+ url = http://www.laffeycomputer.com/rpl.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://downloads.laffeycomputer.com/current_builds/rpl-1.4.1.tar.gz
+ source = LICENSE
+ md5sums = 2eb9c18d97040dc301bfaa8aa70e21a4
+ md5sums = dccf3adbdfc376cfb813b05ecb780b70
+
+pkgname = rpl
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ac96d3c0014a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+ rpl v1.4.1 by Joe Laffey, LAFFEY Computer Imaging.
+ Visit http:www.laffeycomputer.com for updates
+ This software is copyright 1998-2008 by Joe Laffey.
+
+ Permission is granted to any individual, institution, or company to use,
+ copy, or redistribute rpl in source code or binary form so long as it is
+ not modified in any way (beyond modifications required to compile or
+ "package"), and it is not sold by itself for a profit.
+ Permission is also granted to bundle rpl in software distributions which
+ are sold for a profit (e.g. CD-ROMs, etc.), as long as there are at least
+ ten programs included in the distribution.
+ In other words, please do NOT release updates or modified versions yourself.
+ If you modify the source code and would like to see your changes incorporated
+ please submit your source code to software@laffeycomputer.com
+ Please report bugs to that address as well.
+
+ rpl IS PROVIDED AS IS AND COMES WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED
+ OR IMPLIED. IN NO EVENT WILL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DAMAGES
+ RESULTING FROM THE USE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fce6f208770
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexej Magura <agm2819*gmail*>
+#
+# Contributor: Douglas Thrift <douglas@douglasthrift.net>
+
+pkgname=rpl
+pkgver=1.4.1
+pkgrel=13
+pkgdesc="UN*X text replacement utility"
+url="http://www.laffeycomputer.com/rpl.html"
+license=("custom")
+arch=('i686' 'x86_64')
+depends=('glibc')
+source=("http://downloads.laffeycomputer.com/current_builds/$pkgname-${pkgver}.tar.gz" "LICENSE")
+md5sums=('2eb9c18d97040dc301bfaa8aa70e21a4' 'dccf3adbdfc376cfb813b05ecb780b70')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man
+
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR=$pkgdir install
+
+ install -Dm 644 $srcdir/LICENSE $pkgdir/usr/share/licenses/rpl/LICENSE
+}