summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-05-18 10:18:52 +0200
committerJohannes Dewender2015-05-18 10:18:52 +0200
commit3a907c0c3fcd15d132595bd32110d29410818c5f (patch)
treefec32608acc5ffcaca652c514b0da27163fc6abf
parentf26375bb655a653152dc8c4a00f029ddf6ccb009 (diff)
downloadaur-3a907c0c3fcd15d132595bd32110d29410818c5f.tar.gz
rpm-org: add patch for lua 5.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--lua-5.3.patch64
3 files changed, 72 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7d025b87edd..a1b713b3402a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rpm-org
pkgdesc = RPM Package Manager - RPM.org fork, used in major RPM distros
pkgver = 4.12.0.1
- pkgrel = 1
+ pkgrel = 3
url = http://www.rpm.org/
arch = i686
arch = x86_64
@@ -24,9 +24,11 @@ pkgbase = rpm-org
source = http://rpm.org/releases/rpm-4.12.x/rpm-4.12.0.1.tar.bz2
source = rpmextract.sh
source = rpmlib-filesystem-check.patch
+ source = lua-5.3.patch
sha1sums = d416bdb249b246b00b2d5d34c66e7f5a68a62524
sha1sums = 74849919207885ae024f1ab8ed68a76474d67ad7
sha1sums = 0c5fa516dde1f10211af896c729e4b00c313e12b
+ sha1sums = e8efa065eb42648ac431a48b083888ae77e8ae4b
pkgname = rpm-org
diff --git a/PKGBUILD b/PKGBUILD
index 6607bc47f3b8..9967a466bd82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=rpm-org
pkgver=4.12.0.1
_pkgver=$pkgver
#_pkgver=4.12.0-rc1
-pkgrel=1
+pkgrel=3
pkgdesc="RPM Package Manager - RPM.org fork, used in major RPM distros"
arch=('i686' 'x86_64')
url=("http://www.rpm.org/")
@@ -21,14 +21,16 @@ options=('!libtool')
provides=("rpm=${pkgver}" 'rpmextract=1.0-4')
#source=(http://rpm.org/releases/testing/rpm-${_pkgver}.tar.bz2
source=(http://rpm.org/releases/rpm-4.12.x/rpm-${pkgver}.tar.bz2
- rpmextract.sh rpmlib-filesystem-check.patch)
+ rpmextract.sh rpmlib-filesystem-check.patch lua-5.3.patch)
sha1sums=('d416bdb249b246b00b2d5d34c66e7f5a68a62524'
'74849919207885ae024f1ab8ed68a76474d67ad7'
- '0c5fa516dde1f10211af896c729e4b00c313e12b')
+ '0c5fa516dde1f10211af896c729e4b00c313e12b'
+ 'e8efa065eb42648ac431a48b083888ae77e8ae4b')
prepare() {
cd ${srcdir}/rpm-${_pkgver}
patch -p1 < ../rpmlib-filesystem-check.patch
+ patch -p1 < ../lua-5.3.patch
}
diff --git a/lua-5.3.patch b/lua-5.3.patch
new file mode 100644
index 000000000000..dd8062a8777a
--- /dev/null
+++ b/lua-5.3.patch
@@ -0,0 +1,64 @@
+From 82c0aa33c904274d9d62b629c2d15990aab45050 Mon Sep 17 00:00:00 2001
+From: Johannes Dewender <rpm@JonnyJD.net>
+Date: Mon, 18 May 2015 10:11:13 +0200
+Subject: [PATCH] remove luaL_checkint, deprecated in lua 5.3
+
+luaL_checkint and luaL_optint are deprecated in lua 5.3
+The variants luaL_checkinteger and luaL_optinteger work
+the same with an implicit typecast (lua_integer -> int).
+---
+ luaext/lposix.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/luaext/lposix.c b/luaext/lposix.c
+index a59be3e..51ea2b3 100644
+--- a/luaext/lposix.c
++++ b/luaext/lposix.c
+@@ -361,22 +361,22 @@ static int Pfork(lua_State *L) /** fork() */
+
+ static int Pwait(lua_State *L) /** wait([pid]) */
+ {
+- pid_t pid = luaL_optint(L, 1, -1);
++ pid_t pid = luaL_optinteger(L, 1, -1);
+ return pushresult(L, waitpid(pid, NULL, 0), NULL);
+ }
+
+
+ static int Pkill(lua_State *L) /** kill(pid,[sig]) */
+ {
+- pid_t pid = luaL_checkint(L, 1);
+- int sig = luaL_optint(L, 2, SIGTERM);
++ pid_t pid = luaL_checkinteger(L, 1);
++ int sig = luaL_optinteger(L, 2, SIGTERM);
+ return pushresult(L, kill(pid, sig), NULL);
+ }
+
+
+ static int Psleep(lua_State *L) /** sleep(seconds) */
+ {
+- unsigned int seconds = luaL_checkint(L, 1);
++ unsigned int seconds = luaL_checkinteger(L, 1);
+ lua_pushnumber(L, sleep(seconds));
+ return 1;
+ }
+@@ -529,7 +529,7 @@ static int Pgetprocessid(lua_State *L) /** getprocessid([selector]) */
+
+ static int Pttyname(lua_State *L) /** ttyname(fd) */
+ {
+- int fd=luaL_optint(L, 1, 0);
++ int fd=luaL_optinteger(L, 1, 0);
+ lua_pushstring(L, ttyname(fd));
+ return 1;
+ }
+@@ -880,7 +880,7 @@ static int exit_override(lua_State *L)
+ if (!have_forked)
+ return luaL_error(L, "exit not permitted in this context");
+
+- exit(luaL_optint(L, 1, EXIT_SUCCESS));
++ exit(luaL_optinteger(L, 1, EXIT_SUCCESS));
+ }
+
+ static const luaL_Reg os_overrides[] =
+--
+2.1.3
+