summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfpqc2016-11-22 22:10:56 -0500
committerfpqc2016-11-22 22:10:56 -0500
commitf01a05fff7b171d279a413d14e5a57cfd1d628bc (patch)
tree3ee295c543d21ac4d25f6a939c0899de454ed288
parentc743b2b449086bb5dd1b2a57145834263e2e6428 (diff)
downloadaur-f01a05fff7b171d279a413d14e5a57cfd1d628bc.tar.gz
Cleaned up pkgbuild and removed the lua patch from the repo
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
-rw-r--r--lua-5.3.patch64
3 files changed, 1 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af2864b3c657..03472fb4ba5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,6 @@ pkgbase = rpm-org
depends = libarchive
depends = libcap
optdepends = libdbus: systemd inhibit plugin
- provides = rpm-org
provides = rpm=4.13.0
provides = rpmextract=1.0-4
conflicts = rpm
diff --git a/PKGBUILD b/PKGBUILD
index 604b0f06dacc..7566b71d6e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ makedepends=('python2' 'python')
optdepends=('libdbus: systemd inhibit plugin')
conflicts=('rpm' 'rpmextract')
options=('!libtool')
-provides=('rpm-org' "rpm=${pkgver}" 'rpmextract=1.0-4')
+provides=("rpm=${pkgver}" 'rpmextract=1.0-4')
source=(https://github.com/rpm-software-management/rpm/releases/download/rpm-${pkgver}-release/rpm-${pkgver}.tar.bz2
rpmextract.sh rpmlib-filesystem-check.patch bfdfix.patch)
sha1sums=('c6ce4f879ca6a75340921093105e5ef9d33381d3'
diff --git a/lua-5.3.patch b/lua-5.3.patch
deleted file mode 100644
index dd8062a8777a..000000000000
--- a/lua-5.3.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 82c0aa33c904274d9d62b629c2d15990aab45050 Mon Sep 17 00:00:00 2001
-From: Johannes Dewender <rpm@JonnyJD.net>
-Date: Mon, 18 May 2015 10:11:13 +0200
-Subject: [PATCH] remove luaL_checkint, deprecated in lua 5.3
-
-luaL_checkint and luaL_optint are deprecated in lua 5.3
-The variants luaL_checkinteger and luaL_optinteger work
-the same with an implicit typecast (lua_integer -> int).
----
- luaext/lposix.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/luaext/lposix.c b/luaext/lposix.c
-index a59be3e..51ea2b3 100644
---- a/luaext/lposix.c
-+++ b/luaext/lposix.c
-@@ -361,22 +361,22 @@ static int Pfork(lua_State *L) /** fork() */
-
- static int Pwait(lua_State *L) /** wait([pid]) */
- {
-- pid_t pid = luaL_optint(L, 1, -1);
-+ pid_t pid = luaL_optinteger(L, 1, -1);
- return pushresult(L, waitpid(pid, NULL, 0), NULL);
- }
-
-
- static int Pkill(lua_State *L) /** kill(pid,[sig]) */
- {
-- pid_t pid = luaL_checkint(L, 1);
-- int sig = luaL_optint(L, 2, SIGTERM);
-+ pid_t pid = luaL_checkinteger(L, 1);
-+ int sig = luaL_optinteger(L, 2, SIGTERM);
- return pushresult(L, kill(pid, sig), NULL);
- }
-
-
- static int Psleep(lua_State *L) /** sleep(seconds) */
- {
-- unsigned int seconds = luaL_checkint(L, 1);
-+ unsigned int seconds = luaL_checkinteger(L, 1);
- lua_pushnumber(L, sleep(seconds));
- return 1;
- }
-@@ -529,7 +529,7 @@ static int Pgetprocessid(lua_State *L) /** getprocessid([selector]) */
-
- static int Pttyname(lua_State *L) /** ttyname(fd) */
- {
-- int fd=luaL_optint(L, 1, 0);
-+ int fd=luaL_optinteger(L, 1, 0);
- lua_pushstring(L, ttyname(fd));
- return 1;
- }
-@@ -880,7 +880,7 @@ static int exit_override(lua_State *L)
- if (!have_forked)
- return luaL_error(L, "exit not permitted in this context");
-
-- exit(luaL_optint(L, 1, EXIT_SUCCESS));
-+ exit(luaL_optinteger(L, 1, EXIT_SUCCESS));
- }
-
- static const luaL_Reg os_overrides[] =
---
-2.1.3
-