summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:45:53 +0200
committerStefan Husmann2015-06-09 00:45:53 +0200
commitef397f6546b6746f0eee4c53e84478746a73b5a6 (patch)
treed686b1d7798943ed758a21edc7f9343f1e42bf06
downloadaur-ef397f6546b6746f0eee4c53e84478746a73b5a6.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..775ca003a0e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rpm2cpio
+ pkgdesc = Convert .rpm files for extraction with /usr/bin/cpio
+ pkgver = 20040702
+ pkgrel = 2
+ url = http://www.paldo.org/paldo/sources
+ arch = any
+ license = custom
+ depends = bzip2
+ depends = gzip
+ depends = perl
+ source = http://www.paldo.org/paldo/sources/rpm2cpio/rpm2cpio-20040702
+ md5sums = 07f64fa3dae6eb8b1b578d01473a5c07
+
+pkgname = rpm2cpio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..287cbd511922
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Douglas Thrift <douglas@douglasthrift.net>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=rpm2cpio
+pkgver=20040702
+pkgrel=2
+arch=('any')
+pkgdesc="Convert .rpm files for extraction with /usr/bin/cpio"
+url="http://www.paldo.org/paldo/sources"
+depends=('bzip2' 'gzip' 'perl')
+license=('custom')
+source=("http://www.paldo.org/paldo/sources/$pkgname/$pkgname-$pkgver")
+md5sums=('07f64fa3dae6eb8b1b578d01473a5c07')
+
+package() {
+ install -D -m 0755 $srcdir/$pkgname-$pkgver $pkgdir/usr/bin/rpm2cpio.pl
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ echo "For the license look into the script itself." > \
+ $pkgdir/usr/share/licenses/$pkgname/license
+}