summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyleUltimate2022-02-18 20:55:43 +0800
committerKyleUltimate2022-02-18 20:55:43 +0800
commit5f1a36e6ecb1f15e619448b827b3b2800515a921 (patch)
tree690036c08f117745cf964b2ceae34c88ee3b7822
parente53afe24b6c0b0f5a7677457fac4b35c58cf3c2d (diff)
downloadaur-5f1a36e6ecb1f15e619448b827b3b2800515a921.tar.gz
Fixes by FabioLolix
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD26
2 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02586f197fac..0b6b4301c52d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,16 +3,14 @@ pkgbase = rpmlauncher
pkgver = 1.0.6+859
pkgrel = 1
arch = x86_64
- license = GPL
+ license = GPL3
+ makedepends = git
makedepends = ninja
makedepends = cmake
makedepends = clang
makedepends = dart
makedepends = flutter-beta
- depends = git
- conflicts = rpmlauncher-bin
- conflicts = rpmlauncher-git
- source = RPMLauncher::git+https://github.com/RPMTW/RPMLauncher#branch=main
+ source = git+https://github.com/RPMTW/RPMLauncher#tag=1.0.6+859
md5sums = SKIP
pkgname = rpmlauncher
diff --git a/PKGBUILD b/PKGBUILD
index 745623584cb7..05af23f5aa16 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,21 @@
+# Maintainer: UltimateKyle
+
pkgname=rpmlauncher
pkgver=1.0.6+859
pkgrel=1
pkgdesc="A multi-functional Minecraft Launcher power by the RPMTW Team, made with Flutter and Dart"
-provides=('rpmlauncher')
-license=('GPL')
-depends=('git')
-makedepends=('ninja' 'cmake' 'clang' 'dart' 'flutter-beta')
+license=('GPL3')
+depends=()
+makedepends=('git' 'ninja' 'cmake' 'clang' 'dart' 'flutter-beta')
arch=('x86_64')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=('rpmlauncher-bin' 'rpmlauncher-git')
-replaces=()
-backup=()
-options=()
-changelog=
-source=('RPMLauncher::git+https://github.com/RPMTW/RPMLauncher#branch=main')
+source=("git+https://github.com/RPMTW/RPMLauncher#branch=main")
md5sums=('SKIP')
-pkgver(){
- cd "RPMLauncher"
- git describe --tags --abbrev=0 | sed 's/[0-9]*\.[0-9]*\.[0-9]*\.//'
-}
+
prepare(){
cd "RPMLauncher"
flutter config --enable-linux-desktop
}
+
build(){
cd "$srcdir/RPMLauncher/"
build_id=`git describe --tags --abbrev=0 | sed 's/[0-9]*\.[0-9]*\.[0-9]*\.//'`
@@ -34,6 +25,7 @@ build(){
flutter build linux --dart-define="build_id=$build_id" --dart-define="version_type=stable" --dart-define="version=$version_id"
chmod +x "$srcdir/RPMLauncher/build/linux/x64/release/bundle/RPMLauncher"
}
+
package() {
mkdir -p "$pkgdir/usr/share/applications"
mkdir -p "$pkgdir/opt/RPMLauncher"