summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2016-06-18 11:42:21 +0200
committerlarchunix2016-06-18 11:42:21 +0200
commit054c3424d7a00835a78ae8555a1f325fc5a3a167 (patch)
tree92026f19d2289f83607189b13aaa659c1815cdcf
parent4b85f8a6ca19582440625afeb1f363c6d65e9f43 (diff)
downloadaur-054c3424d7a00835a78ae8555a1f325fc5a3a167.tar.gz
Update to upstream release 1.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 833146dc5f89..a2453353665a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpmlint
pkgdesc = A tool for checking common errors in rpm packages.
- pkgver = 1.7
+ pkgver = 1.8
pkgrel = 1
url = https://github.com/rpm-software-management/rpmlint
arch = any
@@ -11,8 +11,8 @@ pkgbase = rpmlint
depends = desktop-file-utils
depends = python
depends = rpm-org
- source = https://github.com/rpm-software-management/rpmlint/archive/rpmlint-1.7.tar.gz
- md5sums = 3741c0c8345da4f3c633328fa7b35c9c
+ source = https://github.com/rpm-software-management/rpmlint/archive/rpmlint-1.8.tar.gz
+ md5sums = f168dc8e190c25dc1f409abb3ef47b86
pkgname = rpmlint
diff --git a/PKGBUILD b/PKGBUILD
index 23efb792c0e0..b14d9557a840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Thomas Dziedzic < gostrc at gmail >
pkgname=rpmlint
-pkgver=1.7
+pkgver=1.8
pkgrel=1
pkgdesc='A tool for checking common errors in rpm packages.'
arch=('any')
@@ -12,7 +12,7 @@ depends=('cpio' 'desktop-file-utils' 'python' 'rpm-org')
makedepends=('bash-completion')
checkdepends=('python-pytest')
source=("$url/archive/$pkgname-$pkgver.tar.gz")
-md5sums=('3741c0c8345da4f3c633328fa7b35c9c')
+md5sums=('f168dc8e190c25dc1f409abb3ef47b86')
prepare() {
mv "$pkgname-$pkgname-$pkgver" "$pkgname-$pkgver"
@@ -24,12 +24,12 @@ build() {
make COMPILE_PYC=1
}
-# Tests need a non-empty RPM database on the system
+# Tests work better with a non-empty RPM database on the system
# It may be created using "rpm --initdb"
-#check() {
-# cd "$pkgname-$pkgver"
-# make check
-#}
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
package() {
cd "$pkgname-$pkgver"