summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2022-05-19 15:42:17 +0200
committerCarl Smedstad2022-05-19 15:42:17 +0200
commit9107068d1b6279ef5ee1353ebc6826d3a5e4d403 (patch)
tree08ea2823fba6ad1103e9f9ad64413a77043a93d5
parentc5031c9411cbf7ff161ca732f973a4c5e0490274 (diff)
downloadaur-9107068d1b6279ef5ee1353ebc6826d3a5e4d403.tar.gz
Publish version 2.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Use-different-Python-package-for-ZStandard.patch88
-rw-r--r--PKGBUILD20
3 files changed, 8 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c690ca8dcbb..d808f914a37f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rpmlint
pkgdesc = A tool for checking common errors in rpm packages
- pkgver = 2.2.0
- pkgrel = 2
+ pkgver = 2.3.0
+ pkgrel = 1
url = https://github.com/rpm-software-management/rpmlint
arch = any
license = GPL2
@@ -25,9 +25,7 @@ pkgbase = rpmlint
optdepends = dash: for checking bashisms
optdepends = desktop-file-utils: for checking desktop entries
optdepends = python-pyenchant: for spell checking
- source = rpmlint-2.2.0.tar.gz::https://github.com/rpm-software-management/rpmlint/archive/refs/tags/2.2.0.tar.gz
- source = 0001-Use-different-Python-package-for-ZStandard.patch
- sha256sums = 53d61cb3c31663c8e86703548bec38f21a49cf0e5a4bdb26f7f6bc3cee899178
- sha256sums = 8775c5f66987a8f6a99fdb24cc769a5ca253acdb1f03c96134763ac7eda02f3b
+ source = rpmlint-2.3.0.tar.gz::https://github.com/rpm-software-management/rpmlint/archive/refs/tags/2.3.0.tar.gz
+ sha256sums = ff6271f2e77a76f19caa5ceff9d90e32ef9da3a6140f0726e0e697c0381f496b
pkgname = rpmlint
diff --git a/0001-Use-different-Python-package-for-ZStandard.patch b/0001-Use-different-Python-package-for-ZStandard.patch
deleted file mode 100644
index 6fd55d52b1ae..000000000000
--- a/0001-Use-different-Python-package-for-ZStandard.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 463bef3f91e2051da2f7d861bc2325338ee623a3 Mon Sep 17 00:00:00 2001
-From: Carl Smedstad <carl.smedstad@protonmail.com>
-Date: Mon, 3 Jan 2022 20:54:02 +0100
-Subject: [PATCH] Use different Python package for ZStandard
-
-The Python package zstd does not have an open() function so I suspect the
-intention was to use the zstandard package all along. The zstandard package
-also seems more actively maintained.
----
- .github/workflows/main.yml | 4 ++--
- .packit/rpmlint.spec | 4 ++--
- rpmlint/pkg.py | 2 +-
- setup.py | 2 +-
- 4 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
-index d049a903..a99fea41 100644
---- a/.github/workflows/main.yml
-+++ b/.github/workflows/main.yml
-@@ -49,7 +49,7 @@ jobs:
- python3-flake8-import-order
- python3-flake8-quotes
- python3-pyxdg
-- python3-zstd
-+ python3-zstandard
- python3-toml
- python3-pip
- rpm-build
-@@ -86,7 +86,7 @@ jobs:
- python3-flake8-import-order
- python3-pyxdg
- python3-toml
-- python3-zstd
-+ python3-zstandard
- python3-pip
- rpm-build
- git
-diff --git a/.packit/rpmlint.spec b/.packit/rpmlint.spec
-index 66f89ed1..51ea2f7a 100644
---- a/.packit/rpmlint.spec
-+++ b/.packit/rpmlint.spec
-@@ -28,7 +28,7 @@ BuildRequires: python3-pytest-xdist
- BuildRequires: python3-pyxdg
- BuildRequires: python3-rpm
- BuildRequires: python3-toml
--BuildRequires: python3-zstd
-+BuildRequires: python3-zstandard
- %else
- BuildRequires: python3dist(setuptools)
- # For tests
-@@ -42,7 +42,7 @@ BuildRequires: python3dist(pytest-xdist)
- BuildRequires: python3dist(pyxdg)
- BuildRequires: python3dist(rpm)
- BuildRequires: python3dist(toml)
--BuildRequires: python3dist(zstd)
-+BuildRequires: python3dist(zstandard)
- %endif
-
- # Rest of the test dependencies
-diff --git a/rpmlint/pkg.py b/rpmlint/pkg.py
-index 6532a59f..24e2ad94 100644
---- a/rpmlint/pkg.py
-+++ b/rpmlint/pkg.py
-@@ -22,7 +22,7 @@ except ImportError:
- import rpm
- from rpmlint.helpers import byte_to_string, ENGLISH_ENVIROMENT, print_warning
- from rpmlint.pkgfile import PkgFile
--import zstd
-+import zstandard as zstd
-
-
- DepInfo = namedtuple('DepInfo', ('name', 'flags', 'version'))
-diff --git a/setup.py b/setup.py
-index 5a0e5260..6d2fd64d 100755
---- a/setup.py
-+++ b/setup.py
-@@ -45,7 +45,7 @@ setup(
- 'pyxdg',
- 'rpm',
- 'toml',
-- 'zstd',
-+ 'zstandard',
- 'importlib-metadata;python_version<"3.8"',
- ],
- tests_require=[
---
-2.35.3
-
diff --git a/PKGBUILD b/PKGBUILD
index 6a4b8d00f341..20fd6baf745b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Thomas Dziedzic < gostrc at gmail >
pkgname=rpmlint
-pkgver=2.2.0
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
pkgdesc="A tool for checking common errors in rpm packages"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
@@ -35,20 +35,8 @@ optdepends=(
'desktop-file-utils: for checking desktop entries'
'python-pyenchant: for spell checking'
)
-source=(
- "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
- "0001-Use-different-Python-package-for-ZStandard.patch"
-)
-sha256sums=(
- '53d61cb3c31663c8e86703548bec38f21a49cf0e5a4bdb26f7f6bc3cee899178'
- '8775c5f66987a8f6a99fdb24cc769a5ca253acdb1f03c96134763ac7eda02f3b'
-)
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- patch --forward --strip=1 --input="${srcdir}/0001-Use-different-Python-package-for-ZStandard.patch"
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('ff6271f2e77a76f19caa5ceff9d90e32ef9da3a6140f0726e0e697c0381f496b')
build() {
cd "$pkgname-$pkgver"