summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2019-01-13 11:13:27 +0100
committerlarchunix2019-01-13 11:13:27 +0100
commitb1accd77324789793a99b41ffbc1df989486a98c (patch)
tree77d0bf5c2ebc0e274c9a50542ccad752580aa6da
parentb3161bce5609e061c48ff2e068920e0d452ad7eb (diff)
downloadaur-b1accd77324789793a99b41ffbc1df989486a98c.tar.gz
Update to upstream release 1.11
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81a5fa1dd14a..1d6d22211584 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpmlint
pkgdesc = A tool for checking common errors in rpm packages.
- pkgver = 1.10
+ pkgver = 1.11
pkgrel = 1
url = https://github.com/rpm-software-management/rpmlint
arch = any
@@ -12,8 +12,11 @@ pkgbase = rpmlint
depends = desktop-file-utils
depends = python
depends = rpm-org
- source = https://github.com/rpm-software-management/rpmlint/archive/rpmlint-1.10.tar.gz
- md5sums = e2fb194390e983712bb4e92cb2a6e962
+ optdepends = appstream-glib: for AppData file validation
+ optdepends = python-magic: for file type detection
+ optdepends = python-pyenchant: for spell checking
+ source = https://github.com/rpm-software-management/rpmlint/archive/rpmlint-1.11.tar.gz
+ md5sums = 2642bb6f08f6e2a2f2c0fe9f07634d49
pkgname = rpmlint
diff --git a/PKGBUILD b/PKGBUILD
index e6d4ceabf1cb..2c8d7b489387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Thomas Dziedzic < gostrc at gmail >
pkgname=rpmlint
-pkgver=1.10
+pkgver=1.11
pkgrel=1
pkgdesc='A tool for checking common errors in rpm packages.'
arch=('any')
@@ -11,8 +11,11 @@ license=('GPL2')
depends=('cpio' 'desktop-file-utils' 'python' 'rpm-org')
makedepends=('bash-completion')
checkdepends=('flake8' 'python-pytest')
+optdepends=('appstream-glib: for AppData file validation'
+ 'python-magic: for file type detection'
+ 'python-pyenchant: for spell checking')
source=("$url/archive/$pkgname-$pkgver.tar.gz")
-md5sums=('e2fb194390e983712bb4e92cb2a6e962')
+md5sums=('2642bb6f08f6e2a2f2c0fe9f07634d49')
prepare() {
mv "$pkgname-$pkgname-$pkgver" "$pkgname-$pkgver"
@@ -24,10 +27,9 @@ build() {
make COMPILE_PYC=1
}
-# Tests work better with a non-empty RPM database on the system
+# Tests need a non-empty RPM database on the system
#check() {
# cd "$pkgname-$pkgver"
-# # flake8 report violations making tests fail
# make FLAKE8=true check
#}