summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfft2017-06-01 14:43:52 +0300
committerfft2017-06-20 11:17:23 +0300
commit8e68f136524843062cacc048e8a9b9179912c12a (patch)
treec9423e4eb2cde195b0ba6f1909b0182cf9d601da
downloadaur-8e68f136524843062cacc048e8a9b9179912c12a.tar.gz
first version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aa1dfe89a89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rpmlint-git
+ pkgdesc = A tool for checking common errors in rpm packages.
+ pkgver = 1.9.r43.ge9e447c
+ pkgrel = 1
+ url = https://github.com/rpm-software-management/rpmlint
+ arch = any
+ license = GPL2
+ checkdepends = python-pytest
+ checkdepends = flake8
+ makedepends = git
+ depends = python
+ depends = rpm-org
+ depends = cpio
+ depends = desktop-file-utils
+ source = rpmlint-git::git+https://github.com/rpm-software-management/rpmlint.git#branch=master
+ sha256sums = SKIP
+
+pkgname = rpmlint-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e20c3103c86e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: fft <anonim288@gmail.com>
+
+pkgname=rpmlint-git
+pkgver=1.9.r43.ge9e447c
+pkgrel=1
+pkgdesc='A tool for checking common errors in rpm packages.'
+arch=('any')
+url="https://github.com/rpm-software-management/rpmlint"
+license=('GPL2')
+makedepends=('git')
+checkdepends=('python-pytest' 'flake8')
+depends=('python' 'rpm-org' 'cpio' 'desktop-file-utils')
+source=("${pkgname}::git+https://github.com/rpm-software-management/rpmlint.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long --tags| sed 's/rpmlint-\([0-9\.]*\)-\(.*\)/\1.r\2/;s/-/./g'
+}
+
+check() {
+ cd ${pkgname}
+ make check
+}
+
+package() {
+ cd ${pkgname}
+ make COMPILE_PYC=1 DESTDIR="${pkgdir}" install
+}