summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfft2018-09-06 16:27:42 +0300
committerfft2018-09-06 16:27:42 +0300
commitc7baf44807aecbeaaae4a49b3cce28d835532bc0 (patch)
treed4450bded7f01b59bd325a3f007c51d730394a6a
parentfd58a4dd41670e7d352d45d2595acb56d790f81d (diff)
downloadaur-c7baf44807aecbeaaae4a49b3cce28d835532bc0.tar.gz
update PKGBUILD, build with python distutils
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e20c3103c86e..c55065a99645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: fft <anonim288@gmail.com>
pkgname=rpmlint-git
-pkgver=1.9.r43.ge9e447c
+pkgver=1.10.r184.g3682eaf
pkgrel=1
pkgdesc='A tool for checking common errors in rpm packages.'
arch=('any')
url="https://github.com/rpm-software-management/rpmlint"
license=('GPL2')
makedepends=('git')
-checkdepends=('python-pytest' 'flake8')
depends=('python' 'rpm-org' 'cpio' 'desktop-file-utils')
+conflicts=('rpmlint')
source=("${pkgname}::git+https://github.com/rpm-software-management/rpmlint.git#branch=master")
sha256sums=('SKIP')
@@ -18,12 +18,12 @@ pkgver() {
git describe --long --tags| sed 's/rpmlint-\([0-9\.]*\)-\(.*\)/\1.r\2/;s/-/./g'
}
-check() {
- cd ${pkgname}
- make check
+build() {
+ cd ${pkgname}
+ python setup.py build
}
package() {
cd ${pkgname}
- make COMPILE_PYC=1 DESTDIR="${pkgdir}" install
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}