summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2020-01-07 20:42:35 -0500
committerCody P Schafer2020-01-07 20:42:35 -0500
commit7d96bc43d1eea8be519a29df8436b7f452414dff (patch)
tree77e11962f298f074a49588cd20066483d7e4ffc1
parente801137554957efc1c301c7add0a7e4d6ee08e43 (diff)
downloadaur-7d96bc43d1eea8be519a29df8436b7f452414dff.tar.gz
update to 5.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--0001-avoid-overriding-external-opt-debug-flags.patch35
-rw-r--r--PKGBUILD10
4 files changed, 8 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db79038f0228..3ec68c83de6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rr
pkgdesc = Record and Replay framework: lightweight recording and deterministic debugging
- pkgver = 5.2.0
+ pkgver = 5.3.0
pkgrel = 5
url = http://rr-project.org/
arch = i686
@@ -13,12 +13,8 @@ pkgbase = rr
depends = gdb
depends = capnproto
options = !strip
- source = rr-5.2.0.tar.gz::https://github.com/mozilla/rr/archive/5.2.0.tar.gz
- source = https://github.com/mozilla/rr/commit/53c5bd72bae089616a3ca626b8af240481d70e6f.patch
- source = file://0001-avoid-overriding-external-opt-debug-flags.patch
- sha1sums = 55040be15a87dd93012d7cdbeb8a3fc428ea4b6b
- sha1sums = 9fcafcc3f4474b4352402b39002869a51e77f6df
- sha1sums = SKIP
+ source = rr-5.3.0.tar.gz::https://github.com/mozilla/rr/archive/5.3.0.tar.gz
+ sha1sums = 4ed678804f8fe94a0b0e0556981c48d9b135cc1d
pkgname = rr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37ad42025a9d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/src/
+/pkg/
diff --git a/0001-avoid-overriding-external-opt-debug-flags.patch b/0001-avoid-overriding-external-opt-debug-flags.patch
deleted file mode 100644
index 0f75ca1f7b09..000000000000
--- a/0001-avoid-overriding-external-opt-debug-flags.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 9c30d17783891bbe2bc8715a5cf3699c322b0712 Mon Sep 17 00:00:00 2001
-From: Cody P Schafer <dev@codyps.com>
-Date: Sun, 18 Nov 2018 12:25:05 -0500
-Subject: [PATCH] avoid overriding external opt/debug flags
-
----
- CMakeLists.txt | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index caad1f19..5ebc6998 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -38,15 +38,15 @@ set(rr_VERSION_PATCH 0)
-
- add_definitions(-DRR_VERSION="${rr_VERSION_MAJOR}.${rr_VERSION_MINOR}.${rr_VERSION_PATCH}")
-
--set(FLAGS_COMMON "-msse2 -D__MMX__ -D__SSE__ -D__SSE2__ -D__USE_LARGEFILE64 -pthread -g3")
-+set(FLAGS_COMMON "-msse2 -D__MMX__ -D__SSE__ -D__SSE2__ -D__USE_LARGEFILE64 -pthread")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${FLAGS_COMMON} -Wstrict-prototypes -std=gnu11")
- # Define __STDC_LIMIT_MACROS so |#include <stdint.h>| works as expected.
- # Define __STDC_FORMAT_MACROS so |#include <inttypes.h>| works as expected.
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${FLAGS_COMMON} -D__STDC_LIMIT_MACROS -D__STDC_FORMAT_MACROS -std=c++11")
--set(CMAKE_ASM_FLAGS "${CMAKE_ASM_FLAGS} -g3")
-+set(CMAKE_ASM_FLAGS "${CMAKE_ASM_FLAGS}")
-
- set(RR_FLAGS_DEBUG "-Wall -Wextra -Werror -O0 -DDEBUG -UNDEBUG")
--set(RR_FLAGS_RELEASE "-Wall -Wextra -O2 -UDEBUG -DNDEBUG")
-+set(RR_FLAGS_RELEASE "-Wall -Wextra -UDEBUG -DNDEBUG")
- set(RR_TEST_FLAGS "${RR_FLAGS_DEBUG}")
-
- string(TOLOWER ${CMAKE_BUILD_TYPE} LOWERCASE_CMAKE_BUILD_TYPE)
---
-2.19.1
-
diff --git a/PKGBUILD b/PKGBUILD
index bac61224ee66..f97feb8c427b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Previous maintainer: Joel Teichroeb <joel@teichroeb.net>
pkgname=rr
-pkgver=5.2.0
+pkgver=5.3.0
pkgrel=5
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
@@ -15,18 +15,12 @@ options=(!strip)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
- https://github.com/mozilla/rr/commit/53c5bd72bae089616a3ca626b8af240481d70e6f.patch
- file://0001-avoid-overriding-external-opt-debug-flags.patch
)
-sha1sums=('55040be15a87dd93012d7cdbeb8a3fc428ea4b6b'
- '9fcafcc3f4474b4352402b39002869a51e77f6df'
- 'SKIP')
+sha1sums=('4ed678804f8fe94a0b0e0556981c48d9b135cc1d')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
- patch -Np1 -i "$srcdir/53c5bd72bae089616a3ca626b8af240481d70e6f.patch"
- patch -Np1 -i "$srcdir/0001-avoid-overriding-external-opt-debug-flags.patch"
}
build() {