summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2017-09-20 09:08:04 -0700
committerTechcable2017-09-20 09:13:04 -0700
commitf34850e07e1f1ae524f4010a426bdebf0000888f (patch)
tree8cf6ca59b0d42fa6d9f93fa388748e654948d484
downloadaur-f34850e07e1f1ae524f4010a426bdebf0000888f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0861575c81eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rr-bin
+ pkgdesc = Binary record and Replay framework: lightweight recording and deterministic debugging
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = http://rr-project.org/
+ arch = x86_64
+ license = custom
+ depends = gdb
+ provides = rr
+ conflicts = rr
+ conflicts = rr-git
+ source = https://github.com/mozilla/rr/releases/download/5.0.0/rr-5.0.0-Linux-x86_64.tar.gz
+ source = https://raw.githubusercontent.com/mozilla/rr/5.0.0/LICENSE
+ sha256sums = 49a91c9c9f160a173e06864408178aaffb27db32af9799e3a06efdac1feb6173
+ sha256sums = fa03106ff7c9018337f1b489bdec8763a1a19b857466055f77637a0af7181f32
+
+pkgname = rr-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2089bf350cac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+# Generated files
+LICENSE
+pkg
+src
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecb53f54718f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Nicholas Schlabach <Techcable@techcable.net>
+pkgname=rr-bin
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="Binary record and Replay framework: lightweight recording and deterministic debugging"
+arch=('x86_64')
+url='http://rr-project.org/'
+license=('custom')
+depends=('gdb')
+source=("https://github.com/mozilla/rr/releases/download/$pkgver/rr-$pkgver-Linux-x86_64.tar.gz" "https://raw.githubusercontent.com/mozilla/rr/5.0.0/LICENSE")
+sha256sums=('49a91c9c9f160a173e06864408178aaffb27db32af9799e3a06efdac1feb6173' 'fa03106ff7c9018337f1b489bdec8763a1a19b857466055f77637a0af7181f32')
+provides=('rr')
+conflicts=('rr' 'rr-git')
+
+package() {
+ for binary in 'rr' 'signal-rr-recording.sh' 'rr_page_32' 'rr_exec_stub_32' 'rr_page_64' 'rr_page_32_replay' 'rr_page_64_replay' 'rr_exec_stub'; do
+ install -Dm755 "rr-$pkgver-Linux-x86_64/bin/$binary" "$pkgdir/usr/bin/$binary"
+ done
+ install -Dm755 "rr-$pkgver-Linux-x86_64/lib/rr/librrpreload.so" "$pkgdir/usr/lib/rr/librrpreload.so"
+ install -Dm755 "rr-$pkgver-Linux-x86_64/lib/rr/librrpreload_32.so" "$pkgdir/usr/lib/rr/librrpreload_32.so"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/rr/LICENSE"
+}