summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAtle Solbakken2020-09-07 11:20:04 +0200
committerAtle Solbakken2020-09-07 11:20:04 +0200
commit1068e9364d4c7a3ca5a4f1fc7a9f1a8e2d497a7e (patch)
tree211a480ff34692ac152ad6572b727d20e2559524
downloadaur-1068e9364d4c7a3ca5a4f1fc7a9f1a8e2d497a7e.tar.gz
Add files.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3774153e24f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rrr
+ pkgdesc = ReadRouteRecord
+ pkgver = 1.12
+ pkgrel = 1
+ url = https://www.github.com/atlesn/rrr
+ arch = i686
+ arch = arm64
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python3
+ depends = perl
+ depends = mariadb-clients
+ optdepends = systemd: systemd daemon support
+ provides = rrr
+ source = git+https://github.com/atlesn/rrr.git#branch=archlinux
+ md5sums = SKIP
+
+pkgname = rrr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2db7e56abffe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname="rrr"
+pkgver=1.12
+pkgrel=1
+pkgdesc="ReadRouteRecord"
+arch=('i686' 'arm64' 'x86_64')
+url="https://www.github.com/atlesn/rrr"
+license=('GPL')
+depends=('python3' 'perl' 'mariadb-clients')
+optdepends=('systemd: systemd daemon support')
+makedepends=('git')
+provides=('rrr')
+source=("git+https://github.com/atlesn/$pkgname.git#branch=archlinux")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ make -k check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}/" install
+}