summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2024-03-08 15:53:37 +0000
committerimlonghao2024-03-08 15:53:37 +0000
commitaf5c2f3101a75fa31aa70ebabcd21c6c3d456e57 (patch)
treed5e1f495f353be6faacdc67303a1fea0a413fb24
parentcc0f489d2abbf0e09f494b6322e14eeb1693088a (diff)
downloadaur-af5c2f3101a75fa31aa70ebabcd21c6c3d456e57.tar.gz
update License
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c35a91ac1eb0..2128efaad685 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = rsactftool-git
- pkgdesc = RSA attack tool (mainly for ctf) - retreive private key from weak public key and/or uncipher data
- pkgver = r231.f54e80f
- pkgrel = 1
- url = https://github.com/Ganapati/RsaCtfTool
- arch = any
- license = custom:Beerware
- makedepends = git
- depends = python-pycryptodome
- depends = python-gmpy2
- depends = python-sympy
- depends = python-requests
- depends = python-six
- depends = python-cryptography
- optdepends = sagemath: advisable
- source = rsactftool-git::git+https://github.com/Ganapati/RsaCtfTool
- source = rsactftool-launch-script
- sha256sums = SKIP
- sha256sums = 2f3cebc4d30867bddaa38b3517357298e74c5b4562c04afe65dca6a9ee6dcb44
+ pkgdesc = RSA attack tool (mainly for ctf) - retreive private key from weak public key and/or uncipher data
+ pkgver = r1097.56a71b9
+ pkgrel = 1
+ url = https://github.com/Ganapati/RsaCtfTool
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = git
+ depends = python-pycryptodome
+ depends = python-gmpy2
+ depends = python-sympy
+ depends = python-requests
+ depends = python-six
+ depends = python-psutil
+ depends = python-cryptography
+ optdepends = sagemath: for boneh_durfee / ecm / ecm2 / qicheng / smallfraction attack
+ provides = rsactftool
+ conflicts = rsactftool
+ source = rsactftool-git::git+https://github.com/Ganapati/RsaCtfTool
+ source = rsactftool-launch-script
+ sha256sums = SKIP
+ sha256sums = 2f3cebc4d30867bddaa38b3517357298e74c5b4562c04afe65dca6a9ee6dcb44
pkgname = rsactftool-git
-
diff --git a/PKGBUILD b/PKGBUILD
index fc11ad63c57f..a9610fb30477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Hao Long <aur@esd.cc>
pkgname=rsactftool-git
-pkgver=r231.f54e80f
+pkgver=r1097.56a71b9
pkgrel=1
pkgdesc="RSA attack tool (mainly for ctf) - retreive private key from weak public key and/or uncipher data"
arch=("any")
url="https://github.com/Ganapati/RsaCtfTool"
-license=('custom:Beerware')
+license=('GPL-3.0-or-later')
depends=("python-pycryptodome"
- "python-gmpy2"
- "python-sympy"
- "python-requests"
- "python-six"
- "python-cryptography")
+ "python-gmpy2"
+ "python-sympy"
+ "python-requests"
+ "python-six"
+ "python-psutil"
+ "python-cryptography")
optdepends=('sagemath: for boneh_durfee / ecm / ecm2 / qicheng / smallfraction attack')
makedepends=('git')
provides=('rsactftool')
conflicts=('rsactftool')
source=("$pkgname::git+$url"
- 'rsactftool-launch-script')
+ 'rsactftool-launch-script')
sha256sums=('SKIP'
- '2f3cebc4d30867bddaa38b3517357298e74c5b4562c04afe65dca6a9ee6dcb44')
+ '2f3cebc4d30867bddaa38b3517357298e74c5b4562c04afe65dca6a9ee6dcb44')
pkgver() {
cd "$pkgname"
@@ -32,5 +33,4 @@ package() {
cp -r $pkgname $pkgdir/usr/share/$pkgname
rm -rf $pkgdir/usr/share/$pkgname/.git/
install -Dm755 rsactftool-launch-script $pkgdir/usr/bin/rsactftool
- install -Dm644 $pkgname/LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.md
}