summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcharklie2024-04-02 15:05:22 +0200
committercharklie2024-04-02 15:05:22 +0200
commit06545cfc030d193cc10096c18df2853b3e0ba39d (patch)
treeb54e5e0fca29b734c70385404efda6d3cb1d69bb
parentb0726cc8690b7b6afbd39ae15fb2e63e00a41a93 (diff)
downloadaur-06545cfc030d193cc10096c18df2853b3e0ba39d.tar.gz
create init aur package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59c82a4ef5e5..a974fd77169c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = rsftch
+pkgbase = rsftch-git
pkgdesc = Lightning fast hardware fetch tool written in rust.
pkgver = 0.3.7
pkgrel = 1
@@ -14,4 +14,4 @@ pkgbase = rsftch
source = git+https://github.com/charklie/rsftch.git
sha256sums = SKIP
-pkgname = rsftch
+pkgname = rsftch-git
diff --git a/PKGBUILD b/PKGBUILD
index 6fabb7fc48db..a0b1f0798822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: <Charklie charliejohanid@gmail.com>
-pkgname=rsftch
+pkgname=rsftch-git
+_pkgname=rsftch
pkgver=0.3.7
pkgrel=1
pkgdesc="Lightning fast hardware fetch tool written in rust."
@@ -14,7 +15,7 @@ source=("git+https://github.com/charklie/rsftch.git")
sha256sums=("SKIP")
build() {
- cd "$pkgname"
+ cd "$_pkgname"
git config http.postBuffer 524288000
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
@@ -22,7 +23,7 @@ build() {
}
package() {
- cd "$pkgname"
- install -Dm755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ cd "$_pkgname"
+ install -Dm755 "target/release/$_pkgname" -t "$pkgdir/usr/bin"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}