summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcharklie2024-04-02 15:02:22 +0200
committercharklie2024-04-02 15:02:22 +0200
commitb0726cc8690b7b6afbd39ae15fb2e63e00a41a93 (patch)
tree91e077e8ddeff60800a5747ae6ca2ebed7d23675
downloadaur-b0726cc8690b7b6afbd39ae15fb2e63e00a41a93.tar.gz
create init aur package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59c82a4ef5e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rsftch
+ pkgdesc = Lightning fast hardware fetch tool written in rust.
+ pkgver = 0.3.7
+ pkgrel = 1
+ url = https://github.com/charklie/rsftch
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = git
+ depends = cargo
+ depends = pciutils
+ provides = rsftch
+ conflicts = rsftch
+ source = git+https://github.com/charklie/rsftch.git
+ sha256sums = SKIP
+
+pkgname = rsftch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fabb7fc48db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: <Charklie charliejohanid@gmail.com>
+pkgname=rsftch
+pkgver=0.3.7
+pkgrel=1
+pkgdesc="Lightning fast hardware fetch tool written in rust."
+url="https://github.com/charklie/rsftch"
+depends=('cargo' 'pciutils' 'sqlite' 'gcc-libs' 'glibc')
+makedepends=('git')
+license=("MIT")
+arch=("x86_64" "aarch64")
+provides=("rsftch")
+conflicts=("rsftch")
+source=("git+https://github.com/charklie/rsftch.git")
+sha256sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ git config http.postBuffer 524288000
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}