summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2023-09-19 12:17:49 +0200
committerGilrain2023-09-19 12:17:49 +0200
commitfb81bd062f3751ce82abf0ea0e077e19da3a1e93 (patch)
treed7a7a14ed61cc42ee1708e7f05a6f461a1b1db7e
downloadaur-fb81bd062f3751ce82abf0ea0e077e19da3a1e93.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7964bbc4a887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rsgain
+ pkgdesc = ReplayGain 2.0 loudness normalizer
+ pkgver = 3.4
+ pkgrel = 1
+ url = https://github.com/complexlogic/rsgain
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ depends = fmt
+ depends = libebur128
+ depends = taglib
+ depends = ffmpeg
+ depends = libinih
+ source = https://github.com/complexlogic/rsgain/archive/refs/tags/v3.4.tar.gz
+ sha256sums =
+
+pkgname = rsgain
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7280e54cf277
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+# Contributor: Seqularise
+
+pkgname=rsgain
+pkgver=3.4
+pkgrel=1
+pkgdesc="ReplayGain 2.0 loudness normalizer"
+arch=('x86_64')
+url="https://github.com/complexlogic/rsgain"
+license=('custom')
+depends=('fmt' 'libebur128' 'taglib' 'ffmpeg' 'libinih')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.bz2::https://github.com/complexlogic/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('75df281d1ad2dc34adc84545eef18677ce026260f7da16e4741f4dcf4a53a77cb2b490a65f0cdbb75a4e08be5c36d6dd8c96154295f52b8779d54159798fdb3b')
+
+build() {
+ cmake -B build -S $pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 $pkgname-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}