summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Minligareev2022-07-09 21:25:47 +0500
committerKirill Minligareev2022-07-09 21:25:47 +0500
commitf64313fc315717f45f9f21ec44e1db5996a19adc (patch)
tree6df75e75d7f1a0e316f2ab559a8d12202667c115
parente968ffc614aca111e2a170446bee94ad33f8b89d (diff)
downloadaur-f64313fc315717f45f9f21ec44e1db5996a19adc.tar.gz
fix source, adjust dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 598209bc278a..571cac497819 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = rsgain-git
pkgdesc = ReplayGain 2.0 loudness normalizer
- pkgver = 2.0.1
+ pkgver = 20220709.g1c63a566d60cbf8d1614b3f8aa5c5a00e680ea30
pkgrel = 1
url = https://github.com/complexlogic/rsgain
arch = x86_64
license = BSD
+ makedepends = git
makedepends = cmake
depends = libebur128
depends = taglib
@@ -14,7 +15,8 @@ pkgbase = rsgain-git
depends = libavutil.so
depends = libinih
provides = rsgain
- source = rsgain-git-2.0.1.tar.gz::https://github.com/complexlogic/rsgain-git/archive/refs/tags/v2.0.1.tar.gz
+ conflicts = rsgain
+ source = git+https://github.com/complexlogic/rsgain.git
md5sums = SKIP
pkgname = rsgain-git
diff --git a/PKGBUILD b/PKGBUILD
index 7901b70204a6..8790032570f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
pkgname=rsgain-git
-pkgver=2.0.1
+_pkgname=rsgain
+pkgver=20220709.g1c63a566d60cbf8d1614b3f8aa5c5a00e680ea30
pkgrel=1
-epoch=
pkgdesc="ReplayGain 2.0 loudness normalizer"
arch=('x86_64')
url="https://github.com/complexlogic/rsgain"
license=('BSD')
groups=()
depends=('libebur128' 'taglib' 'libavformat.so' 'libavcodec.so' 'libswresample.so' 'libavutil.so' 'libinih')
-makedepends=('cmake')
+makedepends=('git' 'cmake')
provides=('rsgain')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/complexlogic/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+conflicts=('rsgain')
+source=("git+https://github.com/complexlogic/rsgain.git")
md5sums=('SKIP')
-validpgpkeys=()
+
+pkgver() {
+ cd $_pkgname
+ date +"%Y%m%d"."g$(git rev-parse HEAD)"
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "$_pkgname"
mkdir build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "$pkgname-$pkgver/build"
+ cd "$_pkgname/build"
make DESTDIR="$pkgdir/" install
}