summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2015-06-08 16:10:28 -0400
committerStorm Dragon2015-06-08 16:10:28 -0400
commit238801fd508dbbd35e1423a402d4fb889e77f9eb (patch)
treee7458d7bf4efaab9988e7dd0146efee56bf75443
downloadaur-238801fd508dbbd35e1423a402d4fb889e77f9eb.tar.gz
Initial import.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD32
-rw-r--r--rsgames.desktop12
-rw-r--r--rsgames.install12
-rw-r--r--rsgames.sh5
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcf4587643c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = rsgames
+ pkgdesc = A collection of board, card, and dice games in audio format played online
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://www.rsgames.org/
+ install = rsgames.install
+ arch = any
+ license = Custom
+ makedepends = unzip
+ depends = python2-speechd
+ depends = wxpython
+ depends = wxgtk2.8
+ depends = python2-crypto
+ depends = python2-configobj
+ depends = python2-faulthandler
+ optdepends = espeak: TTS support
+ provides = rsgames
+ conflicts = rsgames
+ source = rsgames.desktop
+ source = rsgames.sh
+ source = http://www.rsgames.org/downloads/rsgclient/rsg-client-linux-2.0.py27.zip
+ md5sums = 109b93bd034fecd5389b68d9bc177547
+ md5sums = 4df8c8964b8ba2f00f6c97aece344e94
+ md5sums = 0d47d8bdcb9f2da1e5b709a63311b776
+
+pkgname = rsgames
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..727baca12183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Storm Dragon <stormdragon2976@gmail.com>
+pkgname=rsgames
+pkgver=2.0
+pkgrel=1
+pkgdesc="A collection of board, card, and dice games in audio format played online"
+arch=('any')
+url="http://www.rsgames.org/"
+source=("$pkgname.desktop" "$pkgname.sh" "http://www.$pkgname.org/downloads/rsgclient/rsg-client-linux-$pkgver.py27.zip")
+license=('Custom')
+depends=('python2-speechd' 'wxpython' 'wxgtk2.8' 'python2-crypto' 'python2-configobj' 'python2-faulthandler')
+makedepends=('unzip')
+optdepends=('espeak: TTS support')
+provides=("$pkgname")
+conflicts=("$pkgname")
+install="$pkgname.install"
+md5sums=('109b93bd034fecd5389b68d9bc177547'
+ '4df8c8964b8ba2f00f6c97aece344e94'
+ '0d47d8bdcb9f2da1e5b709a63311b776')
+
+package()
+ {
+ msg "Starting to build the package..."
+
+ unzip -d "$srcdir/$pkgname" rsg-client-linux-$pkgver.py27.zip
+ cd "$srcdir/$pkgname"
+ install -d "$pkgdir/opt/$pkgname"
+ cp -a * "$pkgdir/opt/$pkgname/"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ }
+
+# vim:set ts=2 sw=2 et:
diff --git a/rsgames.desktop b/rsgames.desktop
new file mode 100644
index 000000000000..1c212e3171a1
--- /dev/null
+++ b/rsgames.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Encoding=UTF-8
+Name=RSGames
+GenericName=A collection of board, card, and dice games in audio format played online
+Comment=A collection of board, card, and dice games in audio format played online
+Path=/opt/rsgames/rsg-client-build/src
+Exec=python2 rsg.pyc
+Terminal=false
+StartupNotify=true
+Categories=Application;Game;ArcadeGame
diff --git a/rsgames.install b/rsgames.install
new file mode 100644
index 000000000000..250e3130d08d
--- /dev/null
+++ b/rsgames.install
@@ -0,0 +1,12 @@
+post_install() {
+_alert
+}
+
+_alert() {
+cat << EOF
+The rsgames client has a bug that doesn't let it clos propperly.
+Instead of selecting quit from the menu, press alt+f4
+When the window manager says it is not responding, force it to close.
+EOF
+}
+
diff --git a/rsgames.sh b/rsgames.sh
new file mode 100644
index 000000000000..c2b59110a3d9
--- /dev/null
+++ b/rsgames.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd /opt/rsgames/rsg-client-build/src
+python2 rsg.pyc
+exit 0