summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCooper Paul EdenDay2017-05-27 15:46:15 -0400
committerCooper Paul EdenDay2017-05-27 15:46:15 -0400
commit9e9e2e86d438a7903a68f321639eef902be3b4ea (patch)
treeae6f79a92ce8e54a6cd5f2793f3534388f8dded4
downloadaur-9e9e2e86d438a7903a68f321639eef902be3b4ea.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6c8fb728018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat May 27 19:46:05 UTC 2017
+pkgbase = rshare
+ pkgdesc = A file sharing program written in Rust.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/cedenday/rshare
+ arch = x86_64
+ license = GPL3
+ source = https://github.com/cedenday/rshare/releases/download/v0.1.1/rshare-v0.1.1--unknown-linux-musl
+ source = https://github.com/cedenday/rshare/releases/download/v0.1.1/rshare-v0.1.1--unknown-linux-musl.asc
+ sha256sums = 7573132e69215e66fd619ef77a783b31d28e6ac3047b362f4970b4fac27c12d0
+ sha256sums = SKIP
+
+pkgname = rshare
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fbf3a7131cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#@IgnoreInspection BashAddShebang
+# Maintainer: Cooper Paul EdenDay <cedenday@protonmail.com>
+pkgname=rshare
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A file sharing program written in Rust.'
+arch=('x86_64')
+url='https://github.com/cedenday/rshare'
+license=('GPL3')
+source=("https://github.com/cedenday/rshare/releases/download/v$pkgver/rshare-v$pkgver-$CARCH-unknown-linux-musl"{,.asc})
+validpgpkeys=('BDB3F8A842A1656CC10B5CD9EE3B8B8C88FC7275')
+sha256sums=('7573132e69215e66fd619ef77a783b31d28e6ac3047b362f4970b4fac27c12d0'
+ 'SKIP')
+
+build() {
+ chmod +x "$pkgname-v$pkgver-$CARCH-unknown-linux-musl"
+
+ ./$pkgname-v$pkgver-$CARCH-unknown-linux-musl completions bash > "$pkgname.bash-completion"
+ ./$pkgname-v$pkgver-$CARCH-unknown-linux-musl completions zsh > "_$pkgname"
+ ./$pkgname-v$pkgver-$CARCH-unknown-linux-musl completions fish > "$pkgname.fish"
+}
+
+package() {
+ install -Dm755 "$pkgname-v$pkgver-$CARCH-unknown-linux-musl" "$pkgdir/usr/bin/$pkgname"
+
+ install -Dm644 "$pkgname.bash-completion" "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -Dm644 "_$pkgname" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ install -Dm644 "$pkgname.fish" "$pkgdir/usr/share/fish/completions/$pkgname.fish"
+}