summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannik Becher2020-01-22 15:41:32 +0100
committerJannik Becher2020-01-22 15:45:07 +0100
commit0657e64f711cfd2f1fa886aff79e888a1c65f701 (patch)
treea7039ebf4bd539827008835f3ba5754229229f58
parent087672826729493f7ca11cdd6d44ba8c2364fbe1 (diff)
downloadaur-0657e64f711cfd2f1fa886aff79e888a1c65f701.tar.gz
using rshells source package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8873e5751932..3496a59fd560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = rshell
pkgdesc = A remote shell for working with MicroPython boards.
- pkgver = 0.0.24
+ pkgver = 0.0.26
pkgrel = 1
url = https://github.com/dhylands/rshell
arch = any
license = MIT
- makedepends = python3
- depends = python
+ makedepends = python-setuptools
depends = python-pyudev
depends = python-pyserial
- source = https://files.pythonhosted.org/packages/5e/70/d48ce2329734b214d81b08b7ba048869eefafac9d5b482dbccd4f7a4dbef/rshell-0.0.24.tar.gz
- md5sums = 6fc1bda8781d1ca77a0d1e37b58620ef
+ provides = rshell
+ conflicts = rshell
+ source = https://files.pythonhosted.org/packages/source/r/rshell/rshell-0.0.26.tar.gz
+ sha256sums = cc447a3c9853a50585d7fdd6356922e8a89debb67932e60cf241f23fbd72db16
pkgname = rshell
diff --git a/PKGBUILD b/PKGBUILD
index 5a824a626eba..d3c649c3f523 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Jannik Becher <becher.jannik@gmail.com>
pkgname=rshell
-pkgver=0.0.24
+_name=${pkgname#python-}
+provides=(rshell)
+conflicts=(rshell)
+pkgver=0.0.26
pkgrel=1
pkgdesc="A remote shell for working with MicroPython boards."
url="https://github.com/dhylands/rshell"
-depends=('python' 'python-pyudev' 'python-pyserial')
-makedepends=('python3')
+depends=('python-pyudev' 'python-pyserial')
+makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=('https://files.pythonhosted.org/packages/5e/70/d48ce2329734b214d81b08b7ba048869eefafac9d5b482dbccd4f7a4dbef/rshell-0.0.24.tar.gz')
-md5sums=('6fc1bda8781d1ca77a0d1e37b58620ef')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('cc447a3c9853a50585d7fdd6356922e8a89debb67932e60cf241f23fbd72db16')
build() {
- cd $srcdir/rshell-0.0.24
+ cd $srcdir/${_name}-${pkgver}
python setup.py build
}
package() {
- cd $srcdir/rshell-0.0.24
- python setup.py install --root="$pkgdir" --optimize=1
+ cd $srcdir/${_name}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}