summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-05-09 16:37:45 +0200
committerChristopher Arndt2020-05-09 16:37:45 +0200
commitabff9ae8a4e907bb3d413bfd81c15f2a1d24597f (patch)
tree63b74358d9f22a562572f47750ca32949981f6c5
parent0657e64f711cfd2f1fa886aff79e888a1c65f701 (diff)
downloadaur-abff9ae8a4e907bb3d413bfd81c15f2a1d24597f.tar.gz
New upstream version 0.0.28
* New package maintainer * Move 'python-setuptools' from makedepends into depends (needed by command line scripts) * Install documenattion and license * Remove unnecessary $_name variable * Add .gitignore file
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3496a59fd560..53342016763b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = rshell
pkgdesc = A remote shell for working with MicroPython boards.
- pkgver = 0.0.26
+ pkgver = 0.0.28
pkgrel = 1
url = https://github.com/dhylands/rshell
arch = any
license = MIT
- makedepends = python-setuptools
depends = python-pyudev
depends = python-pyserial
- provides = rshell
- conflicts = rshell
- source = https://files.pythonhosted.org/packages/source/r/rshell/rshell-0.0.26.tar.gz
- sha256sums = cc447a3c9853a50585d7fdd6356922e8a89debb67932e60cf241f23fbd72db16
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/r/rshell/rshell-0.0.28.tar.gz
+ sha256sums = d28e6bd872734c68a2b6169adf43b6f71c745fa66ec89ae88a975e38c1a636b3
pkgname = rshell
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c38fd1858437
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+rshell-*.tar.gz
+rshell-*.pkg.tar.xz
+rshell-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index d3c649c3f523..2b83aaa9934e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: Jannik Becher <becher.jannik@gmail.com>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Jannik Becher <becher.jannik@gmail.com>
pkgname=rshell
-_name=${pkgname#python-}
-provides=(rshell)
-conflicts=(rshell)
-pkgver=0.0.26
+pkgver=0.0.28
pkgrel=1
pkgdesc="A remote shell for working with MicroPython boards."
url="https://github.com/dhylands/rshell"
-depends=('python-pyudev' 'python-pyserial')
-makedepends=('python-setuptools')
+depends=('python-pyudev' 'python-pyserial' 'python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('cc447a3c9853a50585d7fdd6356922e8a89debb67932e60cf241f23fbd72db16')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('d28e6bd872734c68a2b6169adf43b6f71c745fa66ec89ae88a975e38c1a636b3')
build() {
- cd $srcdir/${_name}-${pkgver}
- python setup.py build
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd $srcdir/${_name}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$srcdir/${pkgname}-${pkgver}"
+ # Python package and scripts
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ # License
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ # Documentation
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}