summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJannik Becher2019-05-14 11:03:35 +0200
committerJannik Becher2019-05-14 11:03:35 +0200
commitf3122cb6d44feb387d9db7a335890ed1ee398d74 (patch)
tree26dc08741c44f5411ca8fae65fec3e45885923d2
downloadaur-f3122cb6d44feb387d9db7a335890ed1ee398d74.tar.gz
building pkgbuild with pip2arch.py
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7638a3d66738
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rshell
+ pkgdesc = A remote shell for working with MicroPython boards.
+ pkgver = 0.0.24
+ pkgrel = 1
+ url = https://github.com/dhylands/rshell
+ arch = any
+ license = MIT
+ makedepends = python3
+ depends = python
+ source = https://files.pythonhosted.org/packages/5e/70/d48ce2329734b214d81b08b7ba048869eefafac9d5b482dbccd4f7a4dbef/rshell-0.0.24.tar.gz
+ md5sums = 6fc1bda8781d1ca77a0d1e37b58620ef
+
+pkgname = rshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..427b434de1cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jannik Becher <becher.jannik@gmail.com>
+
+pkgname=rshell
+pkgver=0.0.24
+pkgrel=1
+pkgdesc="A remote shell for working with MicroPython boards."
+url="https://github.com/dhylands/rshell"
+depends=('python' )
+makedepends=('python3' )
+license=('MIT')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/5e/70/d48ce2329734b214d81b08b7ba048869eefafac9d5b482dbccd4f7a4dbef/rshell-0.0.24.tar.gz')
+md5sums=('6fc1bda8781d1ca77a0d1e37b58620ef')
+
+build() {
+ cd $srcdir/rshell-0.0.24
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/rshell-0.0.24
+ python setup.py install --root="$pkgdir" --optimize=1
+}