summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorS. D. Cloudt2018-09-29 00:10:43 +0200
committerS. D. Cloudt2020-02-14 12:09:16 +0100
commit8a0bf2d2fa59f42de2c94d9bc9fb739519445f11 (patch)
tree4649e1b878d82dc20eefe2b9a177418727f96798
downloadaur-8a0bf2d2fa59f42de2c94d9bc9fb739519445f11.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
-rw-r--r--rsnapshot-daily.timer10
-rw-r--r--rsnapshot-hourly.timer10
-rw-r--r--rsnapshot-monthly.timer10
-rw-r--r--rsnapshot-weekly.timer10
-rw-r--r--rsnapshot@.service8
8 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fea260d1008
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rsnapshot-systemd
+ pkgdesc = Contains systemd services and timers for rsnapshot
+ pkgver = 1.0
+ pkgrel = 0
+ arch = any
+ depends = rsnapshot
+ source = rsnapshot@.service
+ source = rsnapshot-hourly.timer
+ source = rsnapshot-daily.timer
+ source = rsnapshot-weekly.timer
+ source = rsnapshot-monthly.timer
+ sha512sums = d482746e910af55b2fb5d2d2ad8e36ee58f1150f340223b580eb05c26ef11b1a91c348fb80ac45590d48c3153104817f9f856f0dd333f90c542bbe559b60ef9b
+ sha512sums = f25a9fcd5c6e434a5d774a6fbc32eb189c4f4e8ce556ebee01ae65b32ae4af92490a3df7acdabba5390d18dd4fa3eb75eb9339cf2d32041cb1df6790ec876fc1
+ sha512sums = 7fa1e9331da9decc0f4ab3b66b30ceff90edccf7461bcad02772c578c98b7717ac45a9dbc08ec25da70c4732d654c39aecde41f4397676fcc2617867da622e03
+ sha512sums = c95ff77c0d6cb54eabfea1577c22a14b2e31f84380b846b34bf732e0de5df0ebac2cb2490acc112520365ff51ca18b260f9f04930c73e327d4d4ce25ccb99f64
+ sha512sums = d04db84e572b1de9edf7a3b3a2c57b27bdea7da1d635a5527b0b7637458b1c8b86c86636666ad0f95cd12df7282fb68b50e906efbdc1ad1e76cf9b9074cb0382
+
+pkgname = rsnapshot-systemd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37997c6ad2b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef6eb9a5737b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: S. D. Cloudt < stefan dot cloudt at outlook dot com >
+pkgname=rsnapshot-systemd
+pkgver=1.0
+pkgrel=0
+pkgdesc="Contains systemd services and timers for rsnapshot"
+arch=('any')
+depends=('rsnapshot')
+source=('rsnapshot@.service'
+ 'rsnapshot-hourly.timer'
+ 'rsnapshot-daily.timer'
+ 'rsnapshot-weekly.timer'
+ 'rsnapshot-monthly.timer')
+
+package() {
+ install -dm644 "${pkgdir}/etc/systemd/system"
+ install -m644 "${srcdir}/rsnapshot@.service" "${pkgdir}/etc/systemd/system"
+ install -m644 "${srcdir}/rsnapshot-hourly.timer" "${pkgdir}/etc/systemd/system"
+ install -m644 "${srcdir}/rsnapshot-daily.timer" "${pkgdir}/etc/systemd/system"
+ install -m644 "${srcdir}/rsnapshot-weekly.timer" "${pkgdir}/etc/systemd/system"
+ install -m644 "${srcdir}/rsnapshot-monthly.timer" "${pkgdir}/etc/systemd/system"
+}
+sha512sums=(
+ 'd482746e910af55b2fb5d2d2ad8e36ee58f1150f340223b580eb05c26ef11b1a91c348fb80ac45590d48c3153104817f9f856f0dd333f90c542bbe559b60ef9b'
+ 'f25a9fcd5c6e434a5d774a6fbc32eb189c4f4e8ce556ebee01ae65b32ae4af92490a3df7acdabba5390d18dd4fa3eb75eb9339cf2d32041cb1df6790ec876fc1'
+ '7fa1e9331da9decc0f4ab3b66b30ceff90edccf7461bcad02772c578c98b7717ac45a9dbc08ec25da70c4732d654c39aecde41f4397676fcc2617867da622e03'
+ 'c95ff77c0d6cb54eabfea1577c22a14b2e31f84380b846b34bf732e0de5df0ebac2cb2490acc112520365ff51ca18b260f9f04930c73e327d4d4ce25ccb99f64'
+ 'd04db84e572b1de9edf7a3b3a2c57b27bdea7da1d635a5527b0b7637458b1c8b86c86636666ad0f95cd12df7282fb68b50e906efbdc1ad1e76cf9b9074cb0382'
+)
diff --git a/rsnapshot-daily.timer b/rsnapshot-daily.timer
new file mode 100644
index 000000000000..e8851bebf255
--- /dev/null
+++ b/rsnapshot-daily.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=rsnapshot daily timer
+
+[Timer]
+OnCalendar=*-*-* 5:30
+Persistent=true
+Unit=rsnapshot@daily.service
+
+[Install]
+WantedBy=timers.target
diff --git a/rsnapshot-hourly.timer b/rsnapshot-hourly.timer
new file mode 100644
index 000000000000..d25f11b119c8
--- /dev/null
+++ b/rsnapshot-hourly.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=rsnapshot hourly timer
+
+[Timer]
+OnCalendar=*-*-* *:00
+Persistent=true
+Unit=rsnapshot@hourly.service
+
+[Install]
+WantedBy=timers.target
diff --git a/rsnapshot-monthly.timer b/rsnapshot-monthly.timer
new file mode 100644
index 000000000000..998bc4d16bc0
--- /dev/null
+++ b/rsnapshot-monthly.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=rsnapshot monthly timer
+
+[Timer]
+OnCalendar=*-*-1 4:30
+Persistent=true
+Unit=rsnapshot@monthly.service
+
+[Install]
+WantedBy=timers.target
diff --git a/rsnapshot-weekly.timer b/rsnapshot-weekly.timer
new file mode 100644
index 000000000000..e48c96260f1e
--- /dev/null
+++ b/rsnapshot-weekly.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=rsnapshot weekly timer
+
+[Timer]
+OnCalendar=Monday *-*-* 4:30
+Persistent=true
+Unit=rsnapshot@weekly.service
+
+[Install]
+WantedBy=timers.target
diff --git a/rsnapshot@.service b/rsnapshot@.service
new file mode 100644
index 000000000000..fadb9d6993e8
--- /dev/null
+++ b/rsnapshot@.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=rsnapshot (%I) backup
+
+[Service]
+Type=oneshot
+Nice=19
+IOSchedulingClass=idle
+ExecStart=/usr/bin/rsnapshot %I