summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrisc2015-11-23 20:27:32 +0200
committerrisc2015-11-23 20:27:32 +0200
commite32b718bf906a21a6dc2b05a5f5747b650033f0e (patch)
tree00d20701593a2d47427e0b78c0e32624d327ef08
parent9417068aa329e055410fd8d9050c51327a48de84 (diff)
downloadaur-e32b718bf906a21a6dc2b05a5f5747b650033f0e.tar.gz
fork to github and patch regex issue
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--rssdler-0.4.2-fix.diff53
3 files changed, 9 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ae72b469065..c41f8b65fa49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = rssdler
pkgdesc = Utility to automatically download RSS enclosures
pkgver = 0.4.2
- pkgrel = 1
- url = http://code.google.com/p/rssdler/
+ pkgrel = 2
+ url = https://github.com/dwayne80/rssdler/
arch = any
license = GPL2
depends = python2-feedparser
- source = http://rssdler.googlecode.com/files/rssdler-0.4.2.tar.gz
- source = rssdler-0.4.2-fix.diff
+ source = git+https://github.com/dwayne80/rssdler.git
source = config.txt
- md5sums = 2f0aef5611bc1231928b861f717953eb
- md5sums = 2317d4526f1d0e35fbdb0fb48709e058
+ md5sums = SKIP
md5sums = f9bf928e97b4fd996e1c5854990adcad
pkgname = rssdler
diff --git a/PKGBUILD b/PKGBUILD
index 5c9903739f4f..72eb1dd870ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,20 @@
pkgname=rssdler
pkgver=0.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Utility to automatically download RSS enclosures"
arch=('any')
-url="http://code.google.com/p/rssdler/"
+url="https://github.com/dwayne80/rssdler/"
license=('GPL2')
depends=('python2-feedparser')
-source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz
- $pkgname-$pkgver-fix.diff
+source=(git+https://github.com/dwayne80/$pkgname.git
config.txt)
-md5sums=('2f0aef5611bc1231928b861f717953eb'
- '2317d4526f1d0e35fbdb0fb48709e058'
+md5sums=('SKIP'
'f9bf928e97b4fd996e1c5854990adcad')
package() {
- cd "$srcdir/$pkgname${pkgver//\./}"
- patch -Np0 -i ../$pkgname-$pkgver-fix.diff
+ cd "$srcdir/$pkgname"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
install -Dm644 ../config.txt "$pkgdir/usr/share/$pkgname/config.txt"
install -Dm644 userFunctions.py "$pkgdir/usr/share/$pkgname/postDownloadFunctions.py"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/rssdler-0.4.2-fix.diff b/rssdler-0.4.2-fix.diff
deleted file mode 100644
index c936e1432d85..000000000000
--- a/rssdler-0.4.2-fix.diff
+++ /dev/null
@@ -1,53 +0,0 @@
---- rssdler.py 2009-10-01 14:04:26.000000000 +0000
-+++ rssdler.py.new 2011-06-04 18:10:24.922457392 +0000
-@@ -54,6 +54,8 @@
- try: import mechanize
- except ImportError: mechanize = None
-
-+socket.setdefaulttimeout(10)
-+
- # # # # #
- # == Globals ==
- # # # # #
-@@ -189,8 +191,8 @@
- # because those are undesirable formats, but we want to make sure to not match
- # a name that may have those as a substring e.g. enrgy
- # (ok, not a great example, come up with something better and I'll include it)
--# REF from now on (\b indicates a word boundary)
--regExFalse = (\bnrg\b|\bccd\b)
-+# REF from now on (\\b indicates a word boundary)
-+regExFalse = (\\bnrg\\b|\\bccd\\b)
- # the default value, which means it will be ignored
- # regExFalse = None
-
-@@ -228,7 +230,7 @@
- # say for Ubuntu, we don't want want the 'hoary version,
- download1False = hoary.*%(regExFalse)s
- # this will insert the value for regExFalse in place of the %()s expression
--# resulting in: hoarsy.*(\bnrg\b|\bccd\b)
-+# resulting in: hoarsy.*(\\bnrg\\b|\\bccd\\b)
- # note the parantheses are there b/c they are in the original REF
-
- # we don't want to download things like howto, md5 files, etc,
-@@ -781,7 +783,11 @@
- return False
- filename = getFilenameFromHTTP(data.info(), link)
- if not filename: return False
-- size, data2 = getFileSize(data.info(), data)
-+ try: size, data2 = getFileSize(data.info(), data)
-+ except Exception, m:
-+ logging.critical(''.join((traceback.format_exc(), os.linesep,
-+ u'error determining size of file %s' % filename)))
-+ return False
- if size and not checkFileSize(size, threadName, downItemConfig):
- del data, data2
- return None
-@@ -2037,6 +2043,8 @@
- logging.info(u" Attempting to download %s" % getSaved().failedDown[i]['link'])
- if downloadFile( **getSaved().failedDown[i] ):
- logging.info(u"Success!")
-+ logging.debug(u"adding to saved downloads: %s" % getSaved().failedDown[i]['link'])
-+ getSaved().downloads.append(getSaved().failedDown[i]['link'])
- del getSaved().failedDown[ i ]
- getSaved().save()
- else: