summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-07-13 12:17:50 +0800
committerChih-Hsuan Yen2022-07-13 12:17:50 +0800
commitfbb66f746215c8a8d8dc409d1c7393e64a4bc073 (patch)
tree453ae73921a5bf8ea73d2f2434bc35a0404fa0de
parentc65753a5a02ba9a9f7ce4262337b78722b4ece83 (diff)
downloadaur-fbb66f746215c8a8d8dc409d1c7393e64a4bc073.tar.gz
switch to yarn following upstream
Upstream switched to yarn some time ago [1]. This PKGBUILD change ensures the built package uses the same versions of dependencies as upstream and avoids mysterious issues. Also disables syncing to AUR. Now I prefer to sync manually, so that commit messages can be preserved. [1] https://github.com/DIYgod/RSSHub/commit/483ae4593bc9aea66259035f225db73258a32720
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8a2f53e2ba4..1813819a0128 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = rsshub-git
pkgdesc = Everything is RSSible
- pkgver = r6350.47176b672
+ pkgver = r7724.d4a196333
pkgrel = 1
url = https://rsshub.app/
arch = x86_64
license = MIT
makedepends = npm
+ makedepends = yarn
makedepends = node-gyp
makedepends = git
depends = nodejs
diff --git a/PKGBUILD b/PKGBUILD
index 49113a5672c2..66c219c3941e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: YuutaW <i@yuuta.moe>
pkgname=rsshub-git
-pkgver=r6350.47176b672
+pkgver=r7724.d4a196333
pkgrel=1
pkgdesc="Everything is RSSible"
# The built package bundles native Node.js extensions like OpenCC
@@ -10,7 +10,8 @@ arch=('x86_64')
url="https://rsshub.app/"
license=('MIT')
depends=('nodejs')
-makedepends=('npm' 'node-gyp' 'git')
+# rsshub uses yarn, and some deps (ex: re2) uses npm
+makedepends=('npm' 'yarn' 'node-gyp' 'git')
optdepends=(
'chromium: for routes using a headless browser'
)
@@ -45,7 +46,7 @@ build() {
cd $pkgname
# Not using --production here as minify-docker.js needs devDependencies.
# Unused dependencies will be cleaned up, anyway.
- PUPPETEER_SKIP_CHROMIUM_DOWNLOAD=true npm install --cache "${srcdir}/npm-cache"
+ PUPPETEER_SKIP_CHROMIUM_DOWNLOAD=true yarn --cache-folder "${srcdir}/yarn-cache"
# Cleanup node modules, as Dockerfile does.
node ./scripts/docker/minify-docker.js