summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-08-08 12:18:09 +0800
committerKaizhao Zhang2019-08-08 12:18:09 +0800
commitf2e90ad5bc3829c93e2df4e8e9a0abf224fe7376 (patch)
tree781f26d07cdc649d4a2d75d0bbec7ee29ecab458
parent8078c50e5479c03a8bb548fdc9e378b58f24d335 (diff)
downloadaur-f2e90ad5bc3829c93e2df4e8e9a0abf224fe7376.tar.gz
Updated to git commit 713515355ed3aa74ed0b09477bd2eaae7506b77b
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore9
-rw-r--r--01-fixed-print-compatible-in-python3.patch11
-rw-r--r--PKGBUILD20
4 files changed, 24 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8798cfd0a7d..a28993146c25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rst2pdf
pkgdesc = Convert reStructured Text to PDF via ReportLab.
- pkgver = 0.95.dev0+3+e852d59
+ pkgver = 0.95.dev0+4+7135153
pkgrel = 1
url = https://rst2pdf.org
arch = any
@@ -14,14 +14,17 @@ pkgbase = rst2pdf
depends = python-reportlab
depends = python-six
depends = python-smartypants
- depends = python-svglib
+ optdepends = python-sphinx: sphinx
+ optdepends = python-wordaxe>=1.0: hyphenation
+ optdepends = python-svglib: SVG support
+ optdepends = python-aafigure: aafigure support
+ optdepends = python-matplotlib: math support
+ optdepends = python-xhtml2pdf: raw HTML support
provides = rst2pdf
conflicts = python-rst2pdf
conflicts = python2-rst2pdf
- source = git+https://github.com/rst2pdf/rst2pdf.git#commit=e852d591c1fbf57381eeb6922bd9675698cb26a0
- source = 01-fixed-print-compatible-in-python3.patch
+ source = git+https://github.com/rst2pdf/rst2pdf.git#commit=713515355ed3aa74ed0b09477bd2eaae7506b77b
sha256sums = SKIP
- sha256sums = 72ce82472b1e14a28410a30f6aa617d0012a52e2e5612690536acc3d0d7e06e4
pkgname = rst2pdf
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..fb476c40885a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
-pkg/
-src/
-*.tar.*
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!*.sysusers
+!.SRCINFO
diff --git a/01-fixed-print-compatible-in-python3.patch b/01-fixed-print-compatible-in-python3.patch
deleted file mode 100644
index 05280e89db05..000000000000
--- a/01-fixed-print-compatible-in-python3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- rst2pdf/dumpstyle.py.orig 2019-04-22 22:41:45.777708706 +0800
-+++ rst2pdf/dumpstyle.py 2019-04-22 22:41:58.104682948 +0800
-@@ -144,7 +144,7 @@
- def convert(srcname):
- ''' Convert a single file from .json to .style
- '''
-- print srcname
-+ print(srcname)
- sstr = open(srcname, 'rb').read()
- sdata = fixstyle(jloads(sstr))
- dstr = dumps(sdata)
diff --git a/PKGBUILD b/PKGBUILD
index d9a40b22995a..c4de406149d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
-_gitcommit=e852d591c1fbf57381eeb6922bd9675698cb26a0
+_gitcommit=713515355ed3aa74ed0b09477bd2eaae7506b77b
pkgname=rst2pdf
-pkgver=0.95.dev0+3+${_gitcommit:0:7}
+pkgver=0.95.dev0+4+${_gitcommit:0:7}
pkgrel=1
pkgdesc="Convert reStructured Text to PDF via ReportLab."
url="https://rst2pdf.org"
@@ -16,27 +16,27 @@ depends=(
'python-reportlab'
'python-six'
'python-smartypants'
- 'python-svglib' # should be optional
)
makedepends=('python-setuptools')
+optdepends=(
+ 'python-sphinx: sphinx'
+ 'python-wordaxe>=1.0: hyphenation'
+ 'python-svglib: SVG support'
+ 'python-aafigure: aafigure support'
+ 'python-matplotlib: math support'
+ 'python-xhtml2pdf: raw HTML support'
+)
arch=('any')
license=('MIT')
provides=('rst2pdf')
conflicts=('python-rst2pdf' 'python2-rst2pdf')
source=(
"git+https://github.com/rst2pdf/rst2pdf.git#commit=${_gitcommit}"
- 01-fixed-print-compatible-in-python3.patch
)
sha256sums=(
'SKIP'
- '72ce82472b1e14a28410a30f6aa617d0012a52e2e5612690536acc3d0d7e06e4'
)
-prepare() {
- cd "${srcdir}/${pkgname}"
- patch -p0 -i ../01-fixed-print-compatible-in-python3.patch
-}
-
build() {
cd "${srcdir}/${pkgname}"
python setup.py build